aboutsummaryrefslogtreecommitdiff
path: root/net/linuxptp/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2017-03-15 00:10:32 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-03-17 19:54:20 +0100
commit3d8b505356a08a822b3248a73f6910ec4ea0bab4 (patch)
tree9b0e0d9363d31558b032cb371cae9e2bf34f83b4 /net/linuxptp/Makefile
parente7c51f59738f207edd0cd348c55b1047e49b8b37 (diff)
linuxptp: fix libc functionality check in incdefs.sh
The checks in the incdefs.sh script do not fully work when cross compiling. It probably checks the hosts libc. Just provide the settings manually, as our musl at least supports all these features. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'net/linuxptp/Makefile')
-rw-r--r--net/linuxptp/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net/linuxptp/Makefile b/net/linuxptp/Makefile
index a1ad6e38f..e75be1830 100644
--- a/net/linuxptp/Makefile
+++ b/net/linuxptp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=linuxptp
PKG_VERSION:=1.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_MAINTAINER:=Wojciech Dubowik <Wojciech.Dubowik@neratec.com>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
@@ -38,8 +38,10 @@ define Package/linuxptp/description
computers.
endef
+EXTRA_CFLAGS += -DHAVE_CLOCK_ADJTIME -DHAVE_POSIX_SPAWN -DHAVE_ONESTEP_SYNC
+
MAKE_VARS += \
- EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)"
+ EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CFLAGS)"
define Package/linuxptp/install
$(INSTALL_DIR) $(1)/usr/sbin