aboutsummaryrefslogtreecommitdiff
path: root/net/lighttpd
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2023-01-20 20:07:36 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2023-02-20 04:55:39 -0500
commited6fe528c1efc549891144967eefe51a73999511 (patch)
tree19b7ca66211c367cd426e26335f3103789542b56 /net/lighttpd
parent15ee6d0cc389d63c63aa660d51673c70763994ca (diff)
lighttpd: add lighttpd-mod-webdav_min package
add lighttpd-mod-webdav_min package alternative to lighttpd-mod-webdav lighttpd-mod-webdav_min is more minimal than full lighttpd-mod-webdav. lighttpd-mod-webdav_min does not support PROPPATCH, LOCK, UNLOCK, and by not supporting those methods, removes dependencies on libxml2, libsqlite3, and libuuid. Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
Diffstat (limited to 'net/lighttpd')
2 files changed, 29 insertions, 0 deletions
diff --git a/net/lighttpd/Makefile b/net/lighttpd/Makefile
index 86915d1ce..bd3ef7e71 100644
--- a/net/lighttpd/Makefile
+++ b/net/lighttpd/Makefile
@@ -270,6 +270,7 @@ $(eval $(call BuildPlugin,vhostdb_ldap,Virtual Host Database (LDAP),lighttpd-mod
$(eval $(call BuildPlugin,vhostdb_mysql,Virtual Host Database (MariaDB),lighttpd-mod-vhostdb +PACKAGE_lighttpd-mod-vhostdb_mysql:libmariadb,30))
$(eval $(call BuildPlugin,vhostdb_pgsql,Virtual Host Database (PostgreSQL),lighttpd-mod-vhostdb +PACKAGE_lighttpd-mod-vhostdb_pgsql:libpq,30))
$(eval $(call BuildPlugin,webdav,WebDAV,+PACKAGE_lighttpd-mod-webdav:libsqlite3 +PACKAGE_lighttpd-mod-webdav:libuuid +PACKAGE_lighttpd-mod-webdav:libxml2,30))
+$(eval $(call BuildPlugin,webdav_min,WebDAV,,30))
$(eval $(call BuildPlugin,wolfssl,TLS using wolfssl,@LIGHTTPD_SSL +PACKAGE_lighttpd-mod-wolfssl:libwolfssl,30))
$(eval $(call BuildPlugin,wstunnel,Websocket tunneling,$(if $(cryptolib),+PACKAGE_lighttpd-mod-wstunnel:$(cryptolib),),30))
diff --git a/net/lighttpd/patches/020-meson-mod_webdav_min.patch b/net/lighttpd/patches/020-meson-mod_webdav_min.patch
new file mode 100644
index 000000000..6c7ab078e
--- /dev/null
+++ b/net/lighttpd/patches/020-meson-mod_webdav_min.patch
@@ -0,0 +1,28 @@
+From fe6895e5eb2c17ddad6e95faaac7d56d4dd73256 Mon Sep 17 00:00:00 2001
+From: Glenn Strauss <gstrauss@gluelogic.com>
+Date: Fri, 20 Jan 2023 18:48:14 -0500
+Subject: [PATCH] [meson] mod_webdav_min w/o deps: xml2 sqlite3 uuid
+
+---
+ src/meson.build | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -865,6 +865,16 @@ if libsasl.found()
+ ]
+ endif
+
++modules += [
++ [ 'mod_webdav_min', [ 'mod_webdav.c' ],
++ [ libelftc,
++ declare_dependency(compile_args: [
++ '-DMOD_WEBDAV_BUILD_MINIMAL',
++ '-Dmod_webdav_plugin_init=mod_webdav_min_plugin_init' ] )
++ ]
++ ]
++]
++
+ foreach mod: modules
+ mod_name = mod.get(0)
+ mod_sources = mod.get(1)