aboutsummaryrefslogtreecommitdiff
path: root/net/libreswan/Makefile
diff options
context:
space:
mode:
authorSergey V. Lobanov <sergey@lobanov.in>2022-01-20 23:57:23 +0300
committerRosen Penev <rosenp@gmail.com>2022-01-20 20:49:08 -0800
commit270e8eabc3c953ea22e545a33ce12af3700748aa (patch)
tree5895348608c1a0613b6ef05365c1ccea687a7258 /net/libreswan/Makefile
parentd6b116cb43802048d883a13e2d2e95eea76ad565 (diff)
libreswan: fix build on macos
libreswan makefile detects macos (darwin) and changes build logic but OpenWrt is always Linux so it is required to specify linux as target platfrom This patch specifies Linux as a target platfrom Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
Diffstat (limited to 'net/libreswan/Makefile')
-rw-r--r--net/libreswan/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/libreswan/Makefile b/net/libreswan/Makefile
index 2b6c96f45..263d6e03f 100644
--- a/net/libreswan/Makefile
+++ b/net/libreswan/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libreswan
PKG_VERSION:=4.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.libreswan.org/
@@ -85,6 +85,8 @@ MAKE_FLAGS+= \
FINALRUNDIR="/var/run/pluto" \
FINALNSSDIR="/etc/ipsec.d" \
MODPROBEARGS="-q" \
+ OSDEP=linux \
+ BUILDENV=linux \
ARCH="$(LINUX_KARCH)" \
define Build/Prepare