aboutsummaryrefslogtreecommitdiff
path: root/net/libndp/Makefile
diff options
context:
space:
mode:
authorThomas Guyot-Sionnest <dermoth@aei.ca>2017-12-11 01:58:26 -0500
committerThomas Guyot-Sionnest <dermoth@aei.ca>2018-12-30 15:14:37 -0500
commit9502b9c65a4dfc60ac951f32b4f4b0b35d476406 (patch)
treed1b37f644411bdf7744a5d2243d4ec9924966fe5 /net/libndp/Makefile
parentbf2521fb4ab853c96828432d4358167f895e6ae1 (diff)
libndp: Add library/tool for Neighbor Discovery Protocol
This is a new package to add tooling for IPv6 Neighbor Discovery Protocol, ndptool. Builds libndp and ndptool. Signed-off-by: Thomas Guyot-Sionnest <dermoth@aei.ca>
Diffstat (limited to 'net/libndp/Makefile')
-rw-r--r--net/libndp/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/net/libndp/Makefile b/net/libndp/Makefile
new file mode 100644
index 000000000..e56547e85
--- /dev/null
+++ b/net/libndp/Makefile
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2017-2018 Thomas Guyot-Sionnest <tguyot@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libndp
+PKG_VERSION:=1.7
+PKG_RELEASE:=1
+PKG_LICENSE:=LGPL-2.1
+PKG_MAINTAINER:=Thomas Guyot-Sionnest <tguyot@gmail.com>
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://libndp.org/files/
+PKG_HASH:=2c480afbffb02792dbae3c13bbfb71d89f735562f2795cca0640ed3428b491b6
+
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libndp
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=NDP Library
+ URL:=https://github.com/jpirko/libndp/
+endef
+
+define Package/libndp/description
+ Library for Neighbor Discovery Protocol
+endef
+
+define Package/libndp/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libndp.so.* $(1)/usr/lib/
+endef
+
+define Package/ndptool
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=NDP Tool
+ URL:=https://github.com/jpirko/libndp/
+ DEPENDS:= +libndp
+endef
+
+define Package/ndptool/description
+ Tool for Neighbor Discovery Protocol
+endef
+
+define Package/ndptool/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ndptool $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,libndp))
+$(eval $(call BuildPackage,ndptool))
+