aboutsummaryrefslogtreecommitdiff
path: root/net/leech/Makefile
diff options
context:
space:
mode:
authorLeong Hui Wong <wong.leonghui@gmail.com>2019-11-06 08:48:25 +0000
committerLeong Hui Wong <wong.leonghui@gmail.com>2019-11-06 17:04:22 +0800
commit2d2bf83541d69b56156778187fcdd4f3554f4fd2 (patch)
tree392de16e97a7cde1ccf52bae44a842fbd61be398 /net/leech/Makefile
parent29b5bfd2d9a97c9f9fba0145d7404fc97a3b0847 (diff)
leech: add new package
A set of scripts that parse RSS feeds and downloads files for you. Recipes are available to send download links to transmission and aria2. Signed-off-by: Leong Hui Wong <wong.leonghui@gmail.com>
Diffstat (limited to 'net/leech/Makefile')
-rw-r--r--net/leech/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/net/leech/Makefile b/net/leech/Makefile
new file mode 100644
index 000000000..d7fcbc30b
--- /dev/null
+++ b/net/leech/Makefile
@@ -0,0 +1,61 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=leech
+PKG_VERSION:=1.7
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://bitbucket.org/alekseyt/leech.git
+PKG_SOURCE_DATE:=2019-07-17
+PKG_SOURCE_VERSION:=2378e7348a8ac8ed23b6d29be81dc3a73080d920
+PKG_MIRROR_HASH:=04ca1d1f2cf614edf871360c1adbc758d9b85b67296af438449367c068ce5320
+
+PKG_MAINTAINER:=Leong Hui Wong <wong.leonghui@gmail.com>
+PKG_LICENSE:=blessing
+PKG_LICENSE_FILES:=COPYING
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/leech
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=Download Manager
+ TITLE:=RSS-feeds parser/files downloader
+ URL:=https://bitbucket.org/alekseyt/leech/
+ DEPENDS:=+xsltproc +curl
+endef
+
+define Package/leech/description
+ leech downloads files for you if you give it RSS-feeds of your favorite
+ trackers. Configuration files are under /etc/leech.
+endef
+
+define Build/Compile
+endef
+
+define Build/Install
+endef
+
+define Package/leech/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/sbin/* $(1)/usr/sbin
+
+ $(INSTALL_DIR) $(1)/etc/leech
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/config/* $(1)/etc/leech
+
+ $(INSTALL_DIR) $(1)/usr/share/leech
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/share/leech/* $(1)/usr/share/leech
+endef
+
+define Package/leech/conffiles
+/etc/leech/default
+/etc/leech/downloads
+/etc/leech/foods
+/etc/leech/wild-downloads
+/etc/leech/reverse-downloads
+endef
+
+$(eval $(call BuildPackage,leech))