aboutsummaryrefslogtreecommitdiff
path: root/net/lcdringer
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2016-10-20 23:23:42 -0400
committerW. Michael Petullo <mike@flyn.org>2016-10-20 23:26:11 -0400
commit3e8342fa538a87391018cfbd13d18accc5819392 (patch)
treea020e3b12bdc0f8aaa2c0efbec0aab10257e9051 /net/lcdringer
parent06e404e1cf9aab2cbb3396766d0eb00e9abbcf53 (diff)
lcdringer: add new package
Lcdringer is a tool which runs on a Raspberry Pi with an LCD display. Lcdringer connects to an XMPP server, listens for messages sent to a particular Jabber ID, and displays these incoming messages while playing an audible alarm. Lcdringer also responds to the messages it receives with an indication of whether or not the audible alarm was acknowledged with a button press. Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'net/lcdringer')
-rw-r--r--net/lcdringer/Makefile54
-rw-r--r--net/lcdringer/files/lcdringer.init16
2 files changed, 70 insertions, 0 deletions
diff --git a/net/lcdringer/Makefile b/net/lcdringer/Makefile
new file mode 100644
index 000000000..f5a982c64
--- /dev/null
+++ b/net/lcdringer/Makefile
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2009-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lcdringer
+PKG_VERSION:=0.0.2
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.flyn.org/projects/lcdringer
+PKG_MD5SUM:=ff3fe82593792c9111f957dd533369fb
+PKG_BUILD_DEPENDS:=+vala
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/lcdringer
+ SECTION:=network
+ CATEGORY:=Network
+ DEPENDS:=+libgee +libgstreamer1 +loudmouth @TARGET_brcm2708
+ TITLE:=lcdringer
+ URL:=http://www.flyn.org/projects/lcdringer/
+endef
+
+define Package/lcdringer/decription
+ A simple Jabber-initiated ringer meant to run on a Raspberry Pi with a PiFace CAD
+endef
+
+define Package/lcdringer/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/bin/lcdringer \
+ $(1)/usr/bin/
+ $(INSTALL_BIN) ./files/lcdringer.init $(1)/etc/init.d/lcdringer
+ $(INSTALL_DIR) $(1)/usr/share/lcdringer
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/share/lcdringer/* \
+ $(1)/usr/share/lcdringer
+endef
+
+$(eval $(call BuildPackage,lcdringer))
diff --git a/net/lcdringer/files/lcdringer.init b/net/lcdringer/files/lcdringer.init
new file mode 100644
index 000000000..1781c1003
--- /dev/null
+++ b/net/lcdringer/files/lcdringer.init
@@ -0,0 +1,16 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2009-2012 OpenWrt.org
+
+START=60
+
+start() {
+ /usr/bin/lcdringer &
+ echo $! > /var/run/lcdringer.pid
+}
+
+stop() {
+ if [ ! -f /var/run/lcdringer.pid ]; then
+ return
+ fi
+ /bin/kill -9 `cat /var/run/lcdringer.pid`
+}