aboutsummaryrefslogtreecommitdiff
path: root/net/kplex/Makefile
diff options
context:
space:
mode:
authorNuno Goncalves <nunojpg@gmail.com>2015-07-28 22:58:18 +0100
committerNuno Goncalves <nunojpg@gmail.com>2015-07-28 22:58:18 +0100
commit3520ff67d8ec8c0dffc1aea1dd501d28ad86d29f (patch)
treeca60f292cf40cf314c2e00c18d870a7d5c3646c1 /net/kplex/Makefile
parent027c400baf54d662ff7b672ac303a3b757e6a3d6 (diff)
add kplex: NMEA-0183 multiplexer and router
Signed-off-by: Nuno Goncalves <nunojpg@gmail.com>
Diffstat (limited to 'net/kplex/Makefile')
-rw-r--r--net/kplex/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/net/kplex/Makefile b/net/kplex/Makefile
new file mode 100644
index 000000000..fc7dc2c47
--- /dev/null
+++ b/net/kplex/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=kplex
+PKG_VERSION:=20150728
+
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/stripydog/kplex.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=fec47cd1877ec7903969adefa4220838a706d940
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+
+PKG_LICENSE:=GPL-3.0+
+PKG_LICENSE_FILES:=COPYING
+
+PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/kplex
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=NMEA-0183 multiplexer and router
+ DEPENDS:=+libpthread
+ URL:=http://www.stripydog.com/kplex/
+endef
+
+define Package/kplex/description
+ Kplex is a program for combining and routing NMEA-0183 data to and from multiple
+ sources and destinations. kplex inputs and outputs may be any of Serial lines,
+ Pseudo Terminals (ptys), Network Interfaces and Files.
+endef
+
+
+define Package/kplex/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/kplex $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,kplex))