aboutsummaryrefslogtreecommitdiff
path: root/net/knxd
diff options
context:
space:
mode:
authorOthmar Truniger <github@truniger.ch>2017-08-28 21:33:59 +0200
committerOthmar Truniger <github@truniger.ch>2017-08-28 21:33:59 +0200
commitf161177524c97b2376836d6da776418e96a8ea26 (patch)
treecb0285b3141289c055b263e31ebc8962cc3b6bc7 /net/knxd
parentb5c75be32b6283c499612c4310bc8965784680ac (diff)
knxd: adopt structure and versioning from new upstream stable release
Signed-off-by: Othmar Truniger <github@truniger.ch>
Diffstat (limited to 'net/knxd')
-rw-r--r--net/knxd/Makefile38
-rw-r--r--net/knxd/files/knxd.config45
-rw-r--r--net/knxd/files/knxd.ini17
-rw-r--r--net/knxd/patches/0099-openwrt.patch6
4 files changed, 29 insertions, 77 deletions
diff --git a/net/knxd/Makefile b/net/knxd/Makefile
index b322ba791..60f507563 100644
--- a/net/knxd/Makefile
+++ b/net/knxd/Makefile
@@ -11,12 +11,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=knxd
-PKG_VERSION=2017-01-18
+PKG_VERSION:=0.14.18
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/knxd/knxd.git
-PKG_SOURCE_VERSION:=8255bf08b6e1a972c1489012b570bf0ff8679cb0
+PKG_SOURCE_VERSION:=5e707fdb7430009a299d3ad849aecf9ccbc8fdf6
PKG_SOURCE_SUBDIR:=$(PKG_NAME)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
@@ -46,52 +46,32 @@ EIB KNX Daemon
endef
define Package/knxd/conffiles
-/etc/config/knxd
-endef
-
-define Package/knxd-tools
- SECTION:=net
- CATEGORY:=Network
- TITLE:=EIB KNX Utils
- DEPENDS:=+libstdcpp +libev
-endef
-
-define Package/knxd-tools/description
-EIB KNX Tools
+/etc/config/knxd.ini
endef
TARGET_CXXFLAGS+= -std=c++0x
TARGET_CXX=$(TARGET_CC)
CONFIGURE_ARGS+= \
- --enable-eibnetip \
- --enable-eibnetiptunnel \
- --enable-eibnetipserver \
--disable-systemd
EXTRA_LDFLAGS+= \
-largp -lstdc++
define Package/knxd/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libeibclient.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/knxd_args $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
- $(RM) $(1)/usr/bin/knxtool
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/knxd/eibwrite-cgi $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/knxd/eibread-cgi $(1)/usr/bin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/knxd.init $(1)/etc/init.d/knxd
$(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_DATA) ./files/knxd.config $(1)/etc/config/knxd
-endef
-
-define Package/knxd-tools/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libeibclient.so* $(1)/usr/lib/
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/knxtool $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/knxd/eibwrite-cgi $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/knxd/eibread-cgi $(1)/usr/bin/
+ $(INSTALL_DATA) ./files/knxd.ini $(1)/etc/config/knxd.ini
endef
$(eval $(call BuildPackage,knxd))
-$(eval $(call BuildPackage,knxd-tools))
diff --git a/net/knxd/files/knxd.config b/net/knxd/files/knxd.config
deleted file mode 100644
index c9893bda4..000000000
--- a/net/knxd/files/knxd.config
+++ /dev/null
@@ -1,45 +0,0 @@
-config daemon args
- # driver:[arg] a Layer-2 driver to use (knxd supports more than one)
- option layer2 ""
- # enable caching of group communication networkstate
- option GroupCache 0
- # FILE start the programm as daemon. Output will be written to FILE if given
- option daemon "/var/log/knxd.log"
- #enable the EIBnet/IP server to answer discovery and description requests (SEARCH, DESCRIPTION)
- option Discovery 1
- # EIBADDR set our EIB address to EIBADDR (default 0.0.1)
- option eibaddr "0.0.1"
- # CLIENT-ADDRS assign addresses ADDRSTART through ADDRSTART+n
- option client-addrs "0.0.2:10"
- # LEVEL set error level
- option error 0
- # PORT listen at TCP port PORT (default 6720)
- option listen_tcp "6720"
- # Interface to use
- option Interface ""
- # wait while sending
- option send-delay ""
- # SERVERNAME name of the EIBnet/IP server (default is 'knxd')
- option Name "OpenWrt"
- # the next Layer2 interface may not enter monitor mode
- option no_monitor 0
- # enable EIBnet/IP Routing in the EIBnet/IP server
- option Routing 0
- # [ip[:port]] starts an EIBnet/IP multicast server
- option Server 1
- # MASK set trace flags (bitmask)
- option trace 0
- # tpuarts backend should generate L2 acks for all group telegrams
- option tpuarts_ack_all_group 0
- # tpuarts backend should generate L2 acks for all individual telegrams
- option tpuarts_ack_all_individual 0
- # tpuarts backend should should use a full interface reset (for Disch TPUART interfaces)
- option tpuarts_disch_reset 0
- # enable EIBnet/IP Tunneling in the EIBnet/IP server
- option Tunnelling 1
- # FILE listen at Unix domain socket FILE (default /tmp/eib)
- option listen_local "/var/run/knxd"
- # example with tpuarts interface
- # option url 'tpuarts:/dev/ttyAMA0'
- # example with IP interface in tunnel mode
- option url 'ip:'
diff --git a/net/knxd/files/knxd.ini b/net/knxd/files/knxd.ini
new file mode 100644
index 000000000..b4193dd5f
--- /dev/null
+++ b/net/knxd/files/knxd.ini
@@ -0,0 +1,17 @@
+[A.tcp]
+server = knxd_tcp
+systemd-ignore = true
+[B.ip]
+driver = ip
+[debug-server]
+name = mcast:knxd
+[main]
+addr = 0.0.1
+background = true
+client-addrs = 0.0.2:10
+connections = A.tcp,server,B.ip
+[server]
+debug = debug-server
+discover = true
+server = ets_router
+tunnel = tunnel
diff --git a/net/knxd/patches/0099-openwrt.patch b/net/knxd/patches/0099-openwrt.patch
index f7e33ed10..b1da96ce9 100644
--- a/net/knxd/patches/0099-openwrt.patch
+++ b/net/knxd/patches/0099-openwrt.patch
@@ -1,8 +1,8 @@
---- a/src/client/Makefile.am 2014-12-21 20:17:14.000000000 +0100
-+++ b/src/client/Makefile.am 2014-12-21 20:18:50.639995000 +0100
+--- a/src/client/Makefile.am 2017-01-25 20:17:14.000000000 +0100
++++ b/src/client/Makefile.am 2017-01-25 20:18:50.639995000 +0100
@@ -4,5 +4,5 @@
BUILDJAVA =
endif
--SUBDIRS=def c $(BUILDJAVA) php perl cs python pascal ruby lua .
+-SUBDIRS=def c $(BUILDJAVA) php perl cs python pascal ruby lua go .
+SUBDIRS=def c $(BUILDJAVA) php perl cs .