aboutsummaryrefslogtreecommitdiff
path: root/net/kismet/Makefile
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-01-07 23:21:07 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-01-09 16:36:02 +0100
commit00fce347a5b054f1d38baaac735a357aad3d0a24 (patch)
tree149661b9b88567dfc7e034cf2dca49446d81dbb1 /net/kismet/Makefile
parentbb089121b38ba0161d7ca524d5220b10e5f3ee69 (diff)
treewide: fix incorrect *_BUILD_DEPENDS
Build depends refer to source package names, not binary package names. In many cases, PKG_BUILD_DEPENDS simply duplicated runtime dependencies of a source package's binary packages; as the corresponding source packages are implicitly added as bulid dependencies, PKG_BUILD_DEPENDS can simply be dropped in these cases. In the other cases, *_BUILD_DEPENDS is fixed to refer to the correct source package name. Dependency of mysql-server is adjusted from libncursesw to libncurses (as libncursesw is a virtual package provided by libncurses), so the build dependency on ncurses is emitted unconditionally. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'net/kismet/Makefile')
-rw-r--r--net/kismet/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/net/kismet/Makefile b/net/kismet/Makefile
index d78754da0..97f56fe89 100644
--- a/net/kismet/Makefile
+++ b/net/kismet/Makefile
@@ -17,8 +17,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www.kismetwireless.net/code
PKG_HASH:=bdb21f153311f1ff3b16621bf0d6740f66369bf0982b0a289c9a12af8847e237
-PKG_BUILD_DEPENDS:=libpcap libncurses libpcre
-
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk