aboutsummaryrefslogtreecommitdiff
path: root/net/kea
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-10-22 10:27:26 -0700
committerRosen Penev <rosenp@gmail.com>2019-10-30 09:36:46 -0700
commitc037c8d988027453214849a098232f86dd4ca4d4 (patch)
tree936d32f64b6bb2865d0c7b35eee7c9c7b1bc36aa /net/kea
parent456a4adee7b44457788be13dd770f357915ec63a (diff)
kea: Remove openssl host dependency
OpenSSL is already built as part of tools (LibreSSL actually) and can be used instead for the host build. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/kea')
-rw-r--r--net/kea/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index f0d8c1cc3..72ce46b9c 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kea
PKG_VERSION:=1.6.0
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.isc.org/isc/kea/$(PKG_VERSION)
@@ -20,7 +20,7 @@ PKG_MAINTAINER:=BangLang Huang<banglang.huang@foxmail.com>, Rosy Song<rosysong@r
PKG_LICENSE:=MPL-2.0
PKG_LICENSE_FILES:=COPYING
-HOST_BUILD_DEPENDS:=boost/host log4cplus/host openssl
+HOST_BUILD_DEPENDS:=boost/host log4cplus/host
PKG_BUILD_DEPENDS:=kea/host
HOST_BUILD_PARALLEL:=1
PKG_BUILD_PARALLEL:=1
@@ -147,7 +147,7 @@ endef
HOST_CONFIGURE_ARGS += \
--with-boost-include="$(STAGING_DIR_HOSTPKG)" \
--with-log4cplus="$(STAGING_DIR_HOSTPKG)" \
- --with-openssl="$(STAGING_DIR)/usr" \
+ --with-openssl="$(STAGING_DIR_HOST)" \
--enable-boost-headers-only \
--enable-static-link \
--enable-generate-messages