aboutsummaryrefslogtreecommitdiff
path: root/net/kea/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-04-02 22:11:53 +0300
committerRosen Penev <rosenp@gmail.com>2022-04-02 14:29:06 -0700
commit58866f3452f55fcc2b635943c02bf37168947363 (patch)
treeb2e8f7c989168603299ab0bc5fdc41bc8ab1d8a3 /net/kea/Makefile
parent2784618ab57a9533a615eb139e87b920f733c002 (diff)
kea: drop host build
The host build is used to build kea-msg-compiler, which is only needed when there are changes to .mes files. Since we're not making any changes to such files, we do not need this. As host build fails for Kea 2.0.2, and the git history for kea doesn't contain any reasoning for enabling it, let's just drop it. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'net/kea/Makefile')
-rw-r--r--net/kea/Makefile35
1 files changed, 0 insertions, 35 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index ae322b5c9..ba8e8b648 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -20,16 +20,12 @@ PKG_MAINTAINER:=BangLang Huang<banglang.huang@foxmail.com>, Rosy Song<rosysong@r
PKG_LICENSE:=MPL-2.0
PKG_LICENSE_FILES:=COPYING
-HOST_BUILD_DEPENDS:=boost/host log4cplus/host
-PKG_BUILD_DEPENDS:=kea/host
-HOST_BUILD_PARALLEL:=1
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/host-build.mk
define Package/kea/Default
SECTION:=net
@@ -194,14 +190,6 @@ define Package/kea-uci/description
endef
###### *************************************************************************
-HOST_CONFIGURE_ARGS += \
- --with-boost-include="$(STAGING_DIR_HOSTPKG)" \
- --with-log4cplus="$(STAGING_DIR_HOSTPKG)" \
- --with-openssl="$(STAGING_DIR_HOST)" \
- --enable-generate-messages
-
-HOST_LDFLAGS += \
- -Wl,--gc-sections,--as-needed
CONFIGURE_ARGS += \
--with-boost-include="$(STAGING_DIR)/usr" \
@@ -223,29 +211,6 @@ TARGET_CXXFLAGS += \
TARGET_LDFLAGS += \
-Wl,--gc-sections,--as-needed
-# Only compile the kea-msg-compiler which we need for
-# package compilation
-define Host/Compile
- +$(HOST_MAKE_VARS) \
- $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/src/lib/exceptions $(HOST_MAKE_FLAGS)
- +$(HOST_MAKE_VARS) \
- $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/src/lib/util $(HOST_MAKE_FLAGS)
- +$(HOST_MAKE_VARS) \
- $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/src/lib/log $(HOST_MAKE_FLAGS)
-endef
-
-define Host/Install
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/lib/log/compiler/kea-msg-compiler \
- $(STAGING_DIR_HOSTPKG)/bin/
-endef
-
-define Build/Compile
- $(INSTALL_DIR) $(PKG_BUILD_DIR)/src/lib/log/compiler
- $(INSTALL_BIN) $(STAGING_DIR_HOSTPKG)/bin/kea-msg-compiler \
- $(PKG_BUILD_DIR)/src/lib/log/compiler/
- $(call Build/Compile/Default)
-endef
-
define Package/kea-libs/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/