aboutsummaryrefslogtreecommitdiff
path: root/net/kcptun/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-12-20 13:36:49 -0800
committerRosen Penev <rosenp@gmail.com>2019-12-20 13:36:49 -0800
commit44be1b65d2ca60f9b44d8d513b9a21231db90ea8 (patch)
tree38d5a1720140f810ba306ce28ef9c974a26f34fa /net/kcptun/Makefile
parent6263f9ec802dfc0fd3304a96c30bb2ebbd898efd (diff)
kcptun: Fix GO_ARCH_DEPENDS
Right now, the buildbots are trying to build this on ARC, which is totally unsupported. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/kcptun/Makefile')
-rw-r--r--net/kcptun/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/kcptun/Makefile b/net/kcptun/Makefile
index f484c0d6e..6b645b546 100644
--- a/net/kcptun/Makefile
+++ b/net/kcptun/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kcptun
PKG_VERSION:=20191112
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/xtaci/kcptun/tar.gz/v${PKG_VERSION}?
@@ -31,6 +31,7 @@ define Package/kcptun-config
SUBMENU:=Web Servers/Proxies
TITLE:=Kcptun Config Scripts
URL:=https://github.com/xtaci/kcptun
+ DEPENDS:=$(GO_ARCH_DEPENDS)
endef
define Package/kcptun-config/install
@@ -47,7 +48,7 @@ define Package/kcptun/Default
SUBMENU:=Web Servers/Proxies
TITLE:=KCP-based Secure Tunnel $(1)
URL:=https://github.com/xtaci/kcptun
- DEPENDS:=+kcptun-config $$(GO_ARCH_DEPENDS)
+ DEPENDS:=+kcptun-config
endef
define Package/kcptun-$(1)/description