aboutsummaryrefslogtreecommitdiff
path: root/net/kadnode
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:09:13 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commit35f4ef76e0c88b690ec55f26aed072c4c5989eff (patch)
treec5b36bb3b16488c4546c3c283b8a6020e3966143 /net/kadnode
parent565866a47210c9711c29173052063779b6d3bcfc (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=gc-sections
See commit da370098 "treewide: add support for "gc-sections" in PKG_BUILD_FLAGS" on the main repository. Note: This only touches packages which use all three parts (-ffunction-sections, -fdata-sections and -Wl,--gc-sections) enabled by this build flag. Some packages only use a subset, and these are left unchanged for now. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'net/kadnode')
-rw-r--r--net/kadnode/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/net/kadnode/Makefile b/net/kadnode/Makefile
index 1adfdf168..2b93f6a51 100644
--- a/net/kadnode/Makefile
+++ b/net/kadnode/Makefile
@@ -14,6 +14,7 @@ PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
PKG_LICENSE:=MIT
PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=gc-sections
include $(INCLUDE_DIR)/package.mk
@@ -71,10 +72,6 @@ endif
MAKE_FLAGS += FEATURES="$(FEATURES)"
-# Make binary smaller
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
-
define Package/kadnode/conffiles
/etc/config/kadnode
endef