aboutsummaryrefslogtreecommitdiff
path: root/net/jool/Makefile
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-10-23 04:52:49 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-10-29 18:36:59 +0100
commitdfd652ff3be7032bc90fdc836d32bb6881d42247 (patch)
tree902154d0bb174e532c6d395a2985b72d7c2945c0 /net/jool/Makefile
parent90a74ed4284adcd391c0564ae1a8ae764e425cc3 (diff)
jool: fix PKG_BUILD_DIR to avoid kernel ABI mismatch
As jool builds a kernel module, a PKG_BUILD_DIR under KERNEL_BUILD_DIR must be used to avoid reusing build artifacts when switching to a different target of the same architecture. Otherwise, kernel ABI mismatches may result, leading to an unusuable module, or build failures like the following: Package kmod-jool is missing dependencies for the following libraries: crypto_hash.ko Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'net/jool/Makefile')
-rw-r--r--net/jool/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/jool/Makefile b/net/jool/Makefile
index 96da55ca1..2656835eb 100644
--- a/net/jool/Makefile
+++ b/net/jool/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=jool
PKG_VERSION:=2017.03.09
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=COPYING
@@ -20,7 +20,7 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.xz
PKG_MIRROR_HASH:=a2c41119be251d4d962234fc78d7122568a5e62484969cc4e80229a0c7422fd4
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
+PKG_BUILD_DIR=$(KERNEL_BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone USE_MUSL:argp-standalone