aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp/patches
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2022-03-13 15:14:21 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2022-03-15 17:18:24 -0600
commit649244dae277c422ba27c185c97d55dbe356b8fe (patch)
tree576de62561b0ae8e901b7c42cd54e4ca33bbb038 /net/isc-dhcp/patches
parent9e4485b1564b552b5780df5327187e73f2b80349 (diff)
isc-dhcp: Update to 4.4.3
Note that on 32-bit ARM with MUSL we don't have Unwind_GetIP() so we need to disable backtraces. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'net/isc-dhcp/patches')
-rw-r--r--net/isc-dhcp/patches/000-compile.patch9
-rw-r--r--net/isc-dhcp/patches/510-bind-CC.patch2
-rw-r--r--net/isc-dhcp/patches/900-pass-in-bindconfig.patch16
3 files changed, 17 insertions, 10 deletions
diff --git a/net/isc-dhcp/patches/000-compile.patch b/net/isc-dhcp/patches/000-compile.patch
deleted file mode 100644
index 664cc63cc..000000000
--- a/net/isc-dhcp/patches/000-compile.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/bind/Makefile.in
-+++ b/bind/Makefile.in
-@@ -116,5 +116,6 @@ uninstall-bind: all
-
- # Include the following so that this Makefile is happy when the parent
- # tries to use them.
-+install-exec:
-
- check distdir distclean dvi installcheck:
diff --git a/net/isc-dhcp/patches/510-bind-CC.patch b/net/isc-dhcp/patches/510-bind-CC.patch
index a2acec3d5..dcee7593c 100644
--- a/net/isc-dhcp/patches/510-bind-CC.patch
+++ b/net/isc-dhcp/patches/510-bind-CC.patch
@@ -13,4 +13,4 @@
+ --without-randomdev > ${binddir}/configure.log); \
fi
- atf:
+ atf: bind1
diff --git a/net/isc-dhcp/patches/900-pass-in-bindconfig.patch b/net/isc-dhcp/patches/900-pass-in-bindconfig.patch
new file mode 100644
index 000000000..75683782a
--- /dev/null
+++ b/net/isc-dhcp/patches/900-pass-in-bindconfig.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -660,6 +660,13 @@ else
+ BINDCONFIG="$BINDCONFIG --with-randomdev=$use_randomdev"
+ fi
+
++AC_ARG_ENABLE(backtrace,
++ AS_HELP_STRING([--enable-backtrace], [use libunwind backtracing (default is yes)]),
++ want_backtrace="$enableval", want_backtrace="yes")
++if test "$want_backtrace" = "no"; then
++ BINDCONFIG="$BINDCONFIG --disable-backtrace"
++fi
++
+ BINDIOMUX="--disable-kqueue --disable-epoll --disable-devpoll"
+ # check kqueue/epoll/devpoll alternative to select
+ AC_ARG_ENABLE(kqueue,