aboutsummaryrefslogtreecommitdiff
path: root/net/irssi/Makefile
diff options
context:
space:
mode:
authorFabian Lipken <dynasticorpheus@gmail.com>2023-09-29 10:39:43 +0200
committerRosen Penev <rosenp@gmail.com>2023-10-01 22:51:53 -0700
commit6c8d81e603f9fe6729ed39703ab5ace1b5b6f6fc (patch)
tree37073df6a66f6416e394a31046c4057740a1081f /net/irssi/Makefile
parent73c053c00fffc2a49a3bc6e4f3ffc16974d6a339 (diff)
irssi: update to 1.4.4
update to 1.4.4 switch to meson remove obsolete patch Signed-off-by: Fabian Lipken <dynasticorpheus@gmail.com>
Diffstat (limited to 'net/irssi/Makefile')
-rw-r--r--net/irssi/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/net/irssi/Makefile b/net/irssi/Makefile
index c5d2cb2e5..85a136bf0 100644
--- a/net/irssi/Makefile
+++ b/net/irssi/Makefile
@@ -8,23 +8,22 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=irssi
-PKG_VERSION:=1.2.3
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.4
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/irssi/irssi/releases/download/$(PKG_VERSION)/
-PKG_HASH:=a647bfefed14d2221fa77b6edac594934dc672c4a560417b1abcbbc6b88d769f
+PKG_HASH:=fefe9ec8c7b1475449945c934a2360ab12693454892be47a6d288c63eb107ead
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:irssi:irssi
-PKG_FIXUP:=autoreconf
-PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
+include $(INCLUDE_DIR)/meson.mk
define Package/irssi
SUBMENU:=Instant Messaging
@@ -42,12 +41,12 @@ endef
TARGET_LDFLAGS += -Wl,--gc-sections
-CONFIGURE_ARGS += \
- --disable-glibtest \
- --with-textui \
- --without-bot \
- --without-perl \
- --without-proxy
+MESON_ARGS += \
+ -Dwithout-textui=no \
+ -Dwith-bot=no \
+ -Dwith-otr=no \
+ -Dwith-perl=no \
+ -Dwith-proxy=no \
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/irssi