aboutsummaryrefslogtreecommitdiff
path: root/net/iputils
diff options
context:
space:
mode:
authorNoah Meyerhans <frodo@morgul.net>2022-01-01 12:35:10 -0800
committerRosen Penev <rosenp@gmail.com>2022-01-10 11:18:09 -0800
commit2978bc1977096184b3f4e18601000db835c15e70 (patch)
tree44d03bed644388d88bf0745784abcca367f49ad7 /net/iputils
parent4e0a711bc259ec4705d1da53de7c8984190e6cc4 (diff)
iputils: bump to 20211215
Drop the tftpd binary, which is no longer provided upstream. Users should switch to the atftp server as a replacement. Avoid executing runtime tests, which are not supported in cross-build environments. Signed-off-by: Noah Meyerhans <frodo@morgul.net>
Diffstat (limited to 'net/iputils')
-rw-r--r--net/iputils/Makefile23
-rw-r--r--net/iputils/patches/001_version_fix.patch4
2 files changed, 5 insertions, 22 deletions
diff --git a/net/iputils/Makefile b/net/iputils/Makefile
index 4b145006f..dc9efb37c 100644
--- a/net/iputils/Makefile
+++ b/net/iputils/Makefile
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iputils
-PKG_VERSION:=20210202
+PKG_VERSION:=20211215
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/iputils/iputils/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=3f557ecfd2ace873801231d2c1f42de73ced9fbc1ef3a438d847688b5fb0e8ab
+PKG_HASH:=b6f67fc705490673ff4471d006221b4a2f1b1180b929d9fefd771352621ccedf
PKG_BUILD_DIR:=$(BUILD_DIR)/iputils-$(PKG_VERSION)
PKG_MAINTAINER:=Noah Meyerhans <frodo@morgul.net>
@@ -38,7 +38,7 @@ MESON_ARGS += \
-DBUILD_ARPING=true \
-DBUILD_CLOCKDIFF=true \
-DBUILD_TRACEPATH=true \
- -DBUILD_TFTPD=true
+ -DSKIP_TESTS=true
define Package/iputils/Default
SECTION:=net
@@ -128,24 +128,7 @@ ifdef CONFIG_TRACEPATH_LEGACY_SYMLINKS
endif
endef
-### tftp
-
-define Package/iputils-tftpd
- $(call Package/iputils/Default)
- TITLE:=iputils-tftpd
-endef
-
-define Package/iputils-tftpd/description
- Trivial File Transfer Protocol server
-endef
-
-define Package/iputils-tftpd/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tftpd $(1)/usr/sbin/
-endef
-
$(eval $(call BuildPackage,iputils-ping))
$(eval $(call BuildPackage,iputils-arping))
$(eval $(call BuildPackage,iputils-clockdiff))
$(eval $(call BuildPackage,iputils-tracepath))
-$(eval $(call BuildPackage,iputils-tftpd))
diff --git a/net/iputils/patches/001_version_fix.patch b/net/iputils/patches/001_version_fix.patch
index e9237903c..ca6c76e9f 100644
--- a/net/iputils/patches/001_version_fix.patch
+++ b/net/iputils/patches/001_version_fix.patch
@@ -1,7 +1,7 @@
Description: set a static version string rather than discern it from git
--- a/meson.build
+++ b/meson.build
-@@ -17,6 +17,7 @@ add_project_arguments(
+@@ -19,6 +19,7 @@ add_project_arguments(
conf = configuration_data()
conf.set_quoted('PACKAGE_NAME', meson.project_name())
@@ -9,7 +9,7 @@ Description: set a static version string rather than discern it from git
conf.set('_GNU_SOURCE', 1, description : 'Enable GNU extensions on systems that have them.')
build_arping = get_option('BUILD_ARPING')
-@@ -207,10 +208,10 @@ foreach h : [
+@@ -208,10 +209,10 @@ foreach h : [
endif
endforeach