aboutsummaryrefslogtreecommitdiff
path: root/net/iperf3
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2021-01-22 13:07:47 +0100
committerFlorian Eckert <fe@dev.tdt.de>2021-01-22 16:27:06 +0100
commit2f5a54397355474116643a5839acd6024e87ff3a (patch)
tree4f52f57ea5cc8f6172ddf68f149a2fa8b9e562fe /net/iperf3
parent2131f33d08737be11aa26af966b9725faab146b9 (diff)
iperf3: import from base
Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'net/iperf3')
-rw-r--r--net/iperf3/Makefile83
1 files changed, 83 insertions, 0 deletions
diff --git a/net/iperf3/Makefile b/net/iperf3/Makefile
new file mode 100644
index 000000000..6f90bc922
--- /dev/null
+++ b/net/iperf3/Makefile
@@ -0,0 +1,83 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iperf
+PKG_VERSION:=3.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://downloads.es.net/pub/iperf
+PKG_HASH:=24b63a26382325f759f11d421779a937b63ca1bc17c44587d2fcfedab60ac038
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=BSD-3-Clause
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+
+DISABLE_NLS:=
+
+define Package/iperf3/default
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Internet Protocol bandwidth measuring tool
+ URL:=https://github.com/esnet/iperf
+endef
+
+define Package/iperf3
+$(call Package/iperf3/default)
+ VARIANT:=nossl
+endef
+
+define Package/iperf3-ssl
+$(call Package/iperf3/default)
+ TITLE+= with iperf_auth support
+ VARIANT:=ssl
+ DEPENDS:= +libopenssl
+endef
+
+TARGET_CFLAGS += -D_GNU_SOURCE
+CONFIGURE_ARGS += --disable-shared
+
+ifeq ($(BUILD_VARIANT),ssl)
+ CONFIGURE_ARGS += --with-openssl="$(STAGING_DIR)/usr"
+else
+ CONFIGURE_ARGS += --without-openssl
+endif
+
+MAKE_FLAGS += noinst_PROGRAMS=
+
+define Package/iperf3/description
+ Iperf is a modern alternative for measuring TCP and UDP bandwidth
+ performance, allowing the tuning of various parameters and
+ characteristics.
+endef
+
+# autoreconf fails if the README file isn't present
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ touch $(PKG_BUILD_DIR)/README
+endef
+
+define Package/iperf3/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/iperf3 $(1)/usr/bin/
+endef
+
+define Package/iperf3-ssl/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/iperf3 $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,iperf3))
+$(eval $(call BuildPackage,iperf3-ssl))