aboutsummaryrefslogtreecommitdiff
path: root/net/ifstat
diff options
context:
space:
mode:
authorNikil Mehta <nikil.mehta@gmail.com>2016-11-25 00:54:50 -0800
committerNikil Mehta <nikil.mehta@gmail.com>2016-11-27 15:17:00 -0800
commit843d8c449d7124139ab9f4b5cba68dce2b47b7f7 (patch)
tree74c4cb796a27265a410b6d7878ddbfc5e1a9c7f5 /net/ifstat
parentcce1bfbfb86d6b53d201041edb7bab5d015a6033 (diff)
ifstat: Add package
Signed-off-by: Nikil Mehta nikil.mehta@gmail.com
Diffstat (limited to 'net/ifstat')
-rw-r--r--net/ifstat/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/net/ifstat/Makefile b/net/ifstat/Makefile
new file mode 100644
index 000000000..c8b7a7092
--- /dev/null
+++ b/net/ifstat/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2016 Nikil Mehta <nikil.mehta@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ifstat
+PKG_VERSION:=1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://gael.roualland.free.fr/ifstat/
+PKG_MD5SUM:=8599063b7c398f9cfef7a9ec699659b25b1c14d2bc0f535aed05ce32b7d9f507
+
+PKG_MAINTAINER:=Nikil Mehta <nikil.mehta@gmail.com>
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ifstat
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=InterFace STATistics Monitoring
+ URL:=http://gael.roualland.free.fr/ifstat/
+ DEPENDS:=+libnetsnmp
+endef
+
+define Package/ifstat/description
+ ifstat is a tool to report network interfaces bandwidth just like
+ vmstat/iostat do for other system counters. It can monitor local
+ interfaces by polling the kernel counters, or remote hosts
+ interfaces using SNMP.
+endef
+
+define Package/ifstat/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/ifstat $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,ifstat))