aboutsummaryrefslogtreecommitdiff
path: root/net/ibrdtnd
diff options
context:
space:
mode:
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-09-06 10:32:11 +0200
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-09-06 10:40:45 +0200
commit896951b852e1321f2de2930b040799870c9639ff (patch)
treecc2e62aef4434cf730ff0248640a5013773adf05 /net/ibrdtnd
parent7d49d4cf44a5cb1dbd47572b150a7658f1148a08 (diff)
ibrdtnd: Add patch to exclude build of documentation using pdflatex
By default the package detects the presence of pdflatex and builds documentation automatically. During the OpenWrt build this behavior is not acceptable. The added patch introduces a configure option to explicitly enable the build of the documentation on request. Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Diffstat (limited to 'net/ibrdtnd')
-rw-r--r--net/ibrdtnd/patches/110-add_configure_options_docs.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/ibrdtnd/patches/110-add_configure_options_docs.patch b/net/ibrdtnd/patches/110-add_configure_options_docs.patch
new file mode 100644
index 000000000..4efdbe2c4
--- /dev/null
+++ b/net/ibrdtnd/patches/110-add_configure_options_docs.patch
@@ -0,0 +1,26 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -138,11 +138,17 @@ AS_IF([test "x$enable_android" = "xyes"], [
+ # Checks for library functions.
+ AC_CHECK_FUNCS([gethostname socket])
+
+- # Check for presence of pdfLaTeX
+- AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
+- if test -z "$PDFLATEX"; then
+- AC_MSG_WARN([Unable to create PDF version of the documentation.])
+- fi
++ AC_ARG_ENABLE([docs],
++ AS_HELP_STRING([--enable-docs], [Build documentation using PDFLaTeX]),
++ [
++ # Check for presence of pdfLaTeX
++ AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
++ if test -z "$PDFLATEX"; then
++ AC_MSG_WARN([Unable to create PDF version of the documentation.])
++ fi
++ ], [
++ PDFLATEX="no"
++ ])
+
+ AC_ARG_ENABLE([libdaemon],
+ AS_HELP_STRING([--disable-libdaemon], [Build without libdaemon support]),
+--