aboutsummaryrefslogtreecommitdiff
path: root/net/ibrdtnd
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-07-07 13:36:49 -0700
committerRosen Penev <rosenp@gmail.com>2021-07-11 00:23:55 -0700
commit77e696ccdceef2c9ea4de4d0e50bbf0344cd3188 (patch)
treea7dd9682d9270e3a3802d3fe2d0b3fb03c4c04cf /net/ibrdtnd
parentf2313569b63c2b22bd940cd3a88dfcb384e25f96 (diff)
ibrdtnd: fix compilation with GCC11
throw() is not compatible with C++17. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/ibrdtnd')
-rw-r--r--net/ibrdtnd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/ibrdtnd/Makefile b/net/ibrdtnd/Makefile
index c23bc325c..f3e4bb5d0 100644
--- a/net/ibrdtnd/Makefile
+++ b/net/ibrdtnd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ibrdtnd
PKG_VERSION:=1.0.1
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
@@ -46,6 +46,8 @@ CONFIGURE_ARGS += \
--without-vmime \
--disable-libdaemon
+TARGET_CXXFLAGS += -std=c++11
+
define Package/ibrdtnd/install
$(INSTALL_DIR) $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dtnd $(1)/usr/sbin/