aboutsummaryrefslogtreecommitdiff
path: root/net/ibrdtnd
diff options
context:
space:
mode:
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-24 11:17:51 +0200
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-24 11:59:06 +0200
commit2c81073f2f1a0d1a45d531a629164267fc19f42e (patch)
treee5265e82629d439b91a76570fa024eafe16ced78 /net/ibrdtnd
parent719ed2b98b8727a4677b673403c7e2c21484cfbf (diff)
ibrdtnd: Disable dependency on wifip2p and vmime library
Since the current release of the package does not provide configure options to disable these dependencies, a patch is necessary. Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Diffstat (limited to 'net/ibrdtnd')
-rw-r--r--net/ibrdtnd/Makefile2
-rw-r--r--net/ibrdtnd/patches/100-add_configure_options.patch75
2 files changed, 76 insertions, 1 deletions
diff --git a/net/ibrdtnd/Makefile b/net/ibrdtnd/Makefile
index a33b31ab1..a75dfff8e 100644
--- a/net/ibrdtnd/Makefile
+++ b/net/ibrdtnd/Makefile
@@ -37,7 +37,7 @@ define Package/ibrdtnd/description
endef
CONFIGURE_ARGS += \
- --with-tls --with-sqlite --with-dht
+ --with-tls --with-sqlite --with-dht --without-wifip2p --without-vmime
define Package/ibrdtnd/install
$(INSTALL_DIR) $(1)/usr/sbin/
diff --git a/net/ibrdtnd/patches/100-add_configure_options.patch b/net/ibrdtnd/patches/100-add_configure_options.patch
new file mode 100644
index 000000000..360bd69a5
--- /dev/null
+++ b/net/ibrdtnd/patches/100-add_configure_options.patch
@@ -0,0 +1,75 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -333,30 +333,46 @@ AS_IF([test "x$enable_android" = "xyes"], [
+ dnl optional parameter: Wifi-P2P support
+ dnl -----------------------------------------------
+
+- PKG_CHECK_MODULES([WIFIP2P], wifip2p >= 0.1 , [
+- with_wifi_p2p="yes"
+- AC_SUBST(WIFIP2P_CFLAGS)
+- AC_SUBST(WIFIP2P_LIBS)
+- AC_DEFINE(WITH_WIFIP2P, [1], ["wifi-p2p support enabled"])
+- ], [
+- with_wifi_p2p="no"
+- AC_MSG_WARN([wifi-p2p library not found. wifi-p2p support is disabled.])
+- ])
++ AC_ARG_WITH([wifip2p],
++ AS_HELP_STRING([--without-wifip2p], [Build without wifip2p support]),
++ [
++ with_wifi_p2p="no"
++ AC_MSG_NOTICE([WIFIP2P support disabled])
++ ], [
++ PKG_CHECK_MODULES([WIFIP2P], wifip2p >= 0.1 , [
++ with_wifi_p2p="yes"
++ AC_SUBST(WIFIP2P_CFLAGS)
++ AC_SUBST(WIFIP2P_LIBS)
++ AC_DEFINE(WITH_WIFIP2P, [1], ["wifi-p2p support enabled"])
++ ], [
++ with_wifi_p2p="no"
++ AC_MSG_WARN([wifi-p2p library not found. wifi-p2p support is disabled.])
++ ])
++ ]
++ )
+
+- dnl -----------------------------------------------
+- dnl optional parameter: VMime support
+- dnl -----------------------------------------------
+-
+- PKG_CHECK_MODULES([VMIME], vmime >= 0.9.1 , [
+- with_vmime="yes"
+- AC_SUBST(VMIME_CFLAGS)
+- AC_SUBST(VMIME_LIBS)
+- AC_DEFINE(HAVE_VMIME, [1], ["Email Convergence Layer is available"])
+- AC_CHECK_HEADERS([vmime/utility/smartPtrInt.hpp])
+- ], [
+- with_vmime="no"
+- AC_MSG_WARN([VMime library not found. Email Convergence Layer is disabled.])
+- ])
++ dnl -----------------------------------------------
++ dnl optional parameter: VMime support
++ dnl -----------------------------------------------
++
++ AC_ARG_WITH([vmime],
++ AS_HELP_STRING([--without-vmime], [Build without vmime support]),
++ [
++ with_vmime="no"
++ AC_MSG_NOTICE([VMIME support disabled])
++ ], [
++ PKG_CHECK_MODULES([VMIME], vmime >= 0.9.1 , [
++ with_vmime="yes"
++ AC_SUBST(VMIME_CFLAGS)
++ AC_SUBST(VMIME_LIBS)
++ AC_DEFINE(HAVE_VMIME, [1], ["Email Convergence Layer is available"])
++ AC_CHECK_HEADERS([vmime/utility/smartPtrInt.hpp])
++ ], [
++ with_vmime="no"
++ AC_MSG_WARN([VMime library not found. Email Convergence Layer is disabled.])
++ ])
++ ]
++ )
+
+ dnl -----------------------------------------------
+ dnl check for regex capabilities
+--
+1.9.1
+