aboutsummaryrefslogtreecommitdiff
path: root/net/ibrdtn-tools/Makefile
diff options
context:
space:
mode:
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-20 12:40:23 +0200
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-20 12:44:14 +0200
commit437478db945756bd23ea68a5237d7a9e2138a07c (patch)
tree3551a8b42db4b39bfb2503487a371dfab8fcc806 /net/ibrdtn-tools/Makefile
parent02f1617c003592f6af2407cfdf9f85a862a98fdf (diff)
ibrdtn-tools: add new package
This package contains the tools (dtnsend, dtnrecv, dtnping, ...) of IBR-DTN, a modular and lightweight implementation of the bundle protocol (RFC 5050). https://github.com/ibrdtn/ibrdtn Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Diffstat (limited to 'net/ibrdtn-tools/Makefile')
-rw-r--r--net/ibrdtn-tools/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/net/ibrdtn-tools/Makefile b/net/ibrdtn-tools/Makefile
new file mode 100644
index 000000000..00424a7a8
--- /dev/null
+++ b/net/ibrdtn-tools/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ibrdtn-tools
+PKG_VERSION:=0.12.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
+PKG_MD5SUM:=0ce0c6e754263919ad48661967c2f6fd
+PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
+PKG_LICENSE:=Apache-2.0
+
+PKG_INSTALL:=1
+PKG_BUILD_DEPENDS:=libarchive ibrdtn
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ibrdtn-tools
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+ibrdtn +libarchive
+ TITLE:=DTN Tools
+endef
+
+define Package/ibrdtn-tools/description
+ The IBR-DTN Tools include functionality for sending and receiving files (dtnsend/dtnrecv)
+ and a tools to ping a DTN node (dtnping).
+endef
+
+define Package/ibrdtn-tools/install
+ $(INSTALL_DIR) $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtnping $(1)/usr/bin/dtnping
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtnsend $(1)/usr/bin/dtnsend
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtnrecv $(1)/usr/bin/dtnrecv
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtninbox $(1)/usr/bin/dtninbox
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtnoutbox $(1)/usr/bin/dtnoutbox
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtntrigger $(1)/usr/bin/dtntrigger
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtntracepath $(1)/usr/bin/dtntracepath
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtnstream $(1)/usr/bin/dtnstream
+endef
+
+$(eval $(call BuildPackage,ibrdtn-tools))