aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2020-10-28 15:55:16 +0100
committerFlorian Eckert <fe@dev.tdt.de>2020-11-04 08:50:34 +0100
commitf2820aa3281cf1a1a4f1798f3d66191faa53efb2 (patch)
tree7a23d5d74b2f39fb221797891ecac6fd3f588025 /net/haproxy
parent0869415ce7ca900db844c97364f47a3ab2f6043f (diff)
haproxy: use new extra_command function definition
Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'net/haproxy')
-rw-r--r--net/haproxy/Makefile2
-rw-r--r--net/haproxy/files/haproxy.init3
2 files changed, 2 insertions, 3 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index bc1e8cb6f..9faf70e53 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=haproxy
PKG_VERSION:=2.2.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.haproxy.org/download/2.2/src
diff --git a/net/haproxy/files/haproxy.init b/net/haproxy/files/haproxy.init
index de5695204..01d80d781 100644
--- a/net/haproxy/files/haproxy.init
+++ b/net/haproxy/files/haproxy.init
@@ -6,8 +6,6 @@ STOP=80
USE_PROCD=1
-EXTRA_COMMANDS="check"
-
HAPROXY_BIN="/usr/sbin/haproxy"
HAPROXY_CONFIG="/etc/haproxy.cfg"
@@ -20,6 +18,7 @@ start_service() {
procd_close_instance
}
+extra_command "check" "Check haproxy config"
check() {
$HAPROXY_BIN -c -q -V -f $HAPROXY_CONFIG
}