aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy
diff options
context:
space:
mode:
authorChristian Lachner <gladiac@gmail.com>2021-05-14 17:33:42 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2021-05-18 12:28:23 +0300
commit5212a890c68dc4267d393e2414d96a30971107af (patch)
treeda2788ece9057fa330a88a99afdac1b1c2b1b94a /net/haproxy
parent0250239caf322ba7dc80d13b3629372b0786ba48 (diff)
haproxy: Update HAProxy to v2.4.0
- New upstream major release with tons of new features and LTS (see: https://www.haproxy.com/blog/announcing-haproxy-2-4/) - Update haproxy download URL and hash - Activate promtheus exporter support the new way (using USE_PROMEX=1) - Cleaned up haproxy-specific CFLAGS - Changed the halog build to make use of the new Makefile target (admin/halog/halog) Signed-off-by: Christian Lachner <gladiac@gmail.com>
Diffstat (limited to 'net/haproxy')
-rw-r--r--net/haproxy/Makefile25
-rwxr-xr-xnet/haproxy/get-latest-patches.sh4
2 files changed, 14 insertions, 15 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index f1919810e..d2c5dbe38 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -10,12 +10,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=haproxy
-PKG_VERSION:=2.2.14
+PKG_VERSION:=2.4.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://www.haproxy.org/download/2.2/src
-PKG_HASH:=6a9b702f04b07786f3e5878de8172a727acfdfdbc1cefe1c7a438df372f2fb61
+PKG_SOURCE_URL:=https://www.haproxy.org/download/2.4/src
+PKG_HASH:=0a6962adaf5a1291db87e3eb4ddf906a72fed535dbd2255b164b7d8394a53640
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>, \
Christian Lachner <gladiac@gmail.com>
@@ -98,14 +98,13 @@ define Build/Compile
SMALL_OPTS="-DBUFSIZE=16384 -DMAXREWRITE=1030 -DSYSTEM_MAXCONN=165530" \
USE_LINUX_TPROXY=1 USE_LINUX_SPLICE=1 USE_TFO=1 USE_NS=1 \
USE_ZLIB=1 USE_PCRE=1 USE_PCRE_JIT=1 USE_GETADDRINFO=1 \
- USE_THREAD=1 USE_PTHREAD_PSHARED=1 \
+ USE_THREAD=1 USE_PTHREAD_PSHARED=1 USE_PROMEX=1 \
VERSION="$(PKG_VERSION)" SUBVERS="-$(PKG_RELEASE)" \
VERDATE="$(shell date -d @$(SOURCE_DATE_EPOCH) '+%Y/%m/%d')" IGNOREGIT=1 \
$(ADDON) USE_BACKTRACE= \
- CFLAGS="$(TARGET_CFLAGS) -fno-strict-aliasing -Wdeclaration-after-statement -fwrapv -Wno-format-truncation -Wno-unused-label -Wno-sign-compare -Wno-unused-parameter -Wno-old-style-declaration -Wno-ignored-qualifiers -Wno-clobbered -Wno-missing-field-initializers -Wno-implicit-fallthrough -Wno-stringop-overflow -Wno-cast-function-type -Wtype-limits -Wshift-negative-value -Wshift-overflow=2 -Wduplicated-cond -Wnull-dereference" \
+ CFLAGS="$(TARGET_CFLAGS) -fno-strict-aliasing -Wdeclaration-after-statement -Wno-unused-label -Wno-sign-compare -Wno-unused-parameter -Wno-clobbered -Wno-missing-field-initializers -Wno-cast-function-type -Wtype-limits -Wshift-negative-value -Wshift-overflow=2 -Wduplicated-cond -Wnull-dereference -fwrapv -fasynchronous-unwind-tables -Wno-null-dereference" \
LD="$(TARGET_CC)" \
- LDFLAGS="$(TARGET_LDFLAGS) -latomic" \
- EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
+ LDFLAGS="$(TARGET_LDFLAGS) -latomic"
$(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -114,12 +113,12 @@ define Build/Compile
$(MAKE_FLAGS) \
install
- $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR)/contrib/halog \
+ $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
- $(MAKE_FLAGS) \
- OPTIMIZE="$(TARGET_CFLAGS)" \
- ADDLIB="-lcrypto" \
- halog
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
+ admin/halog/halog
endef
define Package/haproxy/install
@@ -146,7 +145,7 @@ endef
define Package/halog/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/contrib/halog/halog $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/admin/halog/halog $(1)/usr/bin/
endef
$(eval $(call BuildPackage,haproxy))
diff --git a/net/haproxy/get-latest-patches.sh b/net/haproxy/get-latest-patches.sh
index 9553746a2..e92ab65f2 100755
--- a/net/haproxy/get-latest-patches.sh
+++ b/net/haproxy/get-latest-patches.sh
@@ -1,7 +1,7 @@
#!/bin/sh
-CLONEURL=https://git.haproxy.org/git/haproxy-2.2.git
-BASE_TAG=v2.2.14
+CLONEURL=https://git.haproxy.org/git/haproxy-2.4.git
+BASE_TAG=v2.4.0
TMP_REPODIR=tmprepo
PATCHESDIR=patches