aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2022-03-06 12:58:59 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2022-03-06 13:06:44 +0100
commit487cc8fb264090f07a6d04f148b46a79f8950d8e (patch)
treed98f0ca63e149b6ddc64b954cb640230406bf75b /net/haproxy
parentcedc95c86234ced637fe94a1deb931fc2771dfe9 (diff)
haproxy: add conflict to packages with SSL or without SSL support
Both packages provide the same packages and should conflict to each other. Fixes: ``` Packages 'haproxy' and 'haproxy-nossl' do not conflict while providing same file: /usr/sbin/haproxy Packages 'haproxy' and 'haproxy-nossl' do not conflict while providing same file: /etc/haproxy.cfg Packages 'haproxy' and 'haproxy-nossl' do not conflict while providing same file: /etc/init.d/haproxy ``` They should not be installed side by side. Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'net/haproxy')
-rw-r--r--net/haproxy/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index cfd356267..d726b8454 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -60,6 +60,7 @@ define Package/haproxy-nossl
TITLE+=without SSL support
VARIANT:=nossl
DEPENDS+= +libpcre +libltdl +zlib +libpthread +liblua5.3 +libatomic
+ CONFLICTS:=haproxy
endef
define Package/haproxy-nossl/description