aboutsummaryrefslogtreecommitdiff
path: root/net/gping
diff options
context:
space:
mode:
authorJonas Jelonek <jelonek.jonas@gmail.com>2024-03-06 14:44:40 +0100
committerTianling Shen <cnsztl@gmail.com>2024-03-16 06:50:14 +0800
commite8cf9d422dcb36f065c35500f526172fe6f62d46 (patch)
tree8e9fa651e571e485eeadfbd5dbeb82d3acca3bfe /net/gping
parentb69ffe14a992fd3deca123415cc3dd9897cf7807 (diff)
gping: new package
gping is ping but with a graph. It graphically plots ping results over time in terminal, allows multiple hosts to ping in parallel, uses coloured output and can also plot the execution time of arbitrary commands. Signed-off-by: Jonas Jelonek <jelonek.jonas@gmail.com>
Diffstat (limited to 'net/gping')
-rw-r--r--net/gping/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/net/gping/Makefile b/net/gping/Makefile
new file mode 100644
index 000000000..d049c67b5
--- /dev/null
+++ b/net/gping/Makefile
@@ -0,0 +1,43 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2024 Jonas Jelonek
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gping
+PKG_VERSION:=1.16.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/orf/gping/tar.gz/$(PKG_NAME)-v$(PKG_VERSION)?
+PKG_HASH:=557dad6e54b5dd23f88224ea7914776b7636672f237d9cbbea59972235ca89a8
+
+PKG_MAINTAINER:=Jonas Jelonek <jelonek.jonas@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_NAME)-v$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=rust/host
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/rust/rust-package.mk
+
+define Package/gping
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Ping but with a graph
+ DEPENDS:=$(RUST_ARCH_DEPENDS)
+ URL:=https://github.com/orf/gping
+endef
+
+define Package/gping/description
+ gping graphically plots ping results over time in terminal, allows
+ multiple hosts to ping in parallel, uses coloured output and can
+ also plot the execution time of arbitrary commands.
+endef
+
+Build/Compile = $(call Build/Compile/Cargo,gping)
+
+$(eval $(call RustBinPackage,gping))
+$(eval $(call BuildPackage,gping))