aboutsummaryrefslogtreecommitdiff
path: root/net/gnurl
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2015-05-31 18:20:45 +0200
committerDaniel Golle <daniel@makrotopia.org>2015-05-31 18:28:40 +0200
commit6bbdfa55df7f0168e1df019eef6c548027b3c4db (patch)
tree4f346728cf6b25a0de8e854a0bca75029ec389c4 /net/gnurl
parentfc488b8b104ed50e6deb8c0e1d9257f0a36f5d6e (diff)
gnurl: reduce feature-set to match specs in README
gnurl's README states quite excatly which CONFIGURE_ARGS to pass, so disable lots of unneeded stuff. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'net/gnurl')
-rw-r--r--net/gnurl/Makefile43
1 files changed, 30 insertions, 13 deletions
diff --git a/net/gnurl/Makefile b/net/gnurl/Makefile
index 370e5bf9f..962cff303 100644
--- a/net/gnurl/Makefile
+++ b/net/gnurl/Makefile
@@ -42,34 +42,51 @@ define Package/libgnurl
$(call Package/gnurl/Default)
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libgnutls +libidn
+ DEPENDS:=+libgnutls +libidn +zlib
TITLE:=A client-side HTTP/HTTPS transfer library
endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
- --disable-debug \
- --disable-ares \
$(call autoconf_bool,CONFIG_IPV6,ipv6) \
- --enable-shared \
- --enable-static \
- --disable-manual \
- --disable-ldap \
- --disable-ldaps \
--with-gnutls="$(STAGING_DIR)/usr" \
- --with-ipv6 \
--with-libidn="$(STAGING_DIR)/usr" \
+ --with-zlib="$(STAGING_DIR)/usr" \
+ --enable-tls-srp \
+ --enable-shared \
+ --enable-static \
--without-axtls \
- --without-ca-bundle \
- --without-ca-path \
- --without-cyassl \
+ --without-libssh2 \
--without-libmetalink \
+ --without-winidn \
--without-librtmp \
+ --without-nghttp2 \
--without-nss \
+ --without-cyassl \
--without-polarssl \
--without-ssl \
- --without-zlib
+ --without-winssl \
+ --without-darwinssl \
+ --disable-ares \
+ --disable-sspi \
+ --disable-ntlm-wb \
+ --disable-ldap \
+ --disable-ldaps \
+ --disable-rtsp \
+ --disable-dict \
+ --disable-telnet \
+ --disable-tftp \
+ --disable-pop3 \
+ --disable-imap \
+ --disable-smtp \
+ --disable-gopher \
+ --disable-file \
+ --disable-ftp \
+ --disable-smb \
+ --disable-debug \
+ --disable-manual \
+ --disable-verbose
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \