aboutsummaryrefslogtreecommitdiff
path: root/net/gnunet
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2022-10-06 10:00:54 -0300
committerDaniel Golle <daniel@makrotopia.org>2022-10-06 23:33:10 +0100
commitf0417960037d5138f9482821560ba7ccdc317fd4 (patch)
treef17ea0214d1ab8faa663c0aa53e995c643cf78ec /net/gnunet
parent671594bec2f108588d365e99d0f3fca6363d4162 (diff)
gnunet: gnunet-rest: add libjose dependency
According to the package's configure.ac, reclaimID OpenID Connect plugin depends on jose. It is installed by the gnunet-rest plugin package: libgnunnetrest_openid_connect.so. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'net/gnunet')
-rw-r--r--net/gnunet/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/gnunet/Makefile b/net/gnunet/Makefile
index 0ce2f75ef..2abb64311 100644
--- a/net/gnunet/Makefile
+++ b/net/gnunet/Makefile
@@ -37,6 +37,7 @@ CONFIGURE_ARGS+= \
--with-extractor=$(STAGING_DIR)/usr \
--with-gnutls=$(STAGING_DIR)/usr \
$(if $(CONFIG_PACKAGE_$(PKG_NAME)-transport-bluetooth),--with-bluetooth="$(STAGING_DIR)/usr",--without-bluetooth) \
+ --with-jose=$(STAGING_DIR)/usr \
--with-libgnurl=$(STAGING_DIR)/usr \
--with-ogg=$(STAGING_DIR)/usr \
--with-opus=$(STAGING_DIR)/usr \
@@ -293,7 +294,7 @@ LIBEXEC_reclaim:=service-consensus service-reclaim service-secretsharing
CONF_reclaim:=consensus reclaim secretsharing
PLUGIN_reclaim:=block_consensus gnsrecord_reclaim reclaim_credential_jwt reclaim_attribute_basic
-DEPENDS_rest:=+gnunet-gns +gnunet-reclaim +libmicrohttpd-ssl +jansson
+DEPENDS_rest:=+gnunet-gns +gnunet-reclaim +libmicrohttpd-ssl +jansson +libjose
LIB_rest:=rest json gnsrecordjson
PLUGIN_rest:=rest_config rest_copying rest_gns rest_identity rest_namestore rest_peerinfo rest_openid_connect rest_reclaim
LIBEXEC_rest:=rest-server