aboutsummaryrefslogtreecommitdiff
path: root/net/git
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2019-10-20 01:58:02 +0200
committertripolar <tripolar@users.noreply.github.com>2019-10-20 12:53:29 +0200
commitd8d736711d02bb9a9fabc2fcbf8a8424e8e6936a (patch)
treeef8e56aee7d70d789504f5b6458f21b431a2f4ec /net/git
parentfa790f08de4478f571311f55093731f72f005cb3 (diff)
git: Update to version 2.23.0
Refresh patches Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'net/git')
-rw-r--r--net/git/Makefile4
-rw-r--r--net/git/patches/100-configure_for_crosscompiling.patch6
-rw-r--r--net/git/patches/200-imapsend_without_curl.patch2
-rw-r--r--net/git/patches/300-openssl-deprecated.patch7
4 files changed, 7 insertions, 12 deletions
diff --git a/net/git/Makefile b/net/git/Makefile
index 42a1adc3d..725a965ae 100644
--- a/net/git/Makefile
+++ b/net/git/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=git
-PKG_VERSION:=2.22.0
+PKG_VERSION:=2.23.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
-PKG_HASH:=159e4b599f8af4612e70b666600a3139541f8bacc18124daf2cbe8d1b934f29f
+PKG_HASH:=234fa05b6839e92dc300b2dd78c92ec9c0c8d439f65e1d430a7034f60af16067
PKG_INSTALL:=1
PKG_FIXUP:=autoreconf
diff --git a/net/git/patches/100-configure_for_crosscompiling.patch b/net/git/patches/100-configure_for_crosscompiling.patch
index 07796e6df..bb7a61d13 100644
--- a/net/git/patches/100-configure_for_crosscompiling.patch
+++ b/net/git/patches/100-configure_for_crosscompiling.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -929,7 +929,8 @@ AC_RUN_IFELSE(
+@@ -952,7 +952,8 @@ AC_RUN_IFELSE(
FILE *f = fopen(".", "r");
return f != NULL;]])],
[ac_cv_fread_reads_directories=no],
@@ -10,7 +10,7 @@
])
if test $ac_cv_fread_reads_directories = yes; then
FREAD_READS_DIRECTORIES=UnfortunatelyYes
-@@ -963,7 +964,8 @@ AC_RUN_IFELSE(
+@@ -986,7 +987,8 @@ AC_RUN_IFELSE(
if (snprintf(buf, 3, "%s", "12345") != 5
|| strcmp(buf, "12")) return 1]])],
[ac_cv_snprintf_returns_bogus=no],
@@ -20,7 +20,7 @@
])
if test $ac_cv_snprintf_returns_bogus = yes; then
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
-@@ -986,7 +988,8 @@ yippeeyeswehaveit
+@@ -1009,7 +1011,8 @@ yippeeyeswehaveit
#endif
]),
[ac_cv_sane_mode_bits=yes],
diff --git a/net/git/patches/200-imapsend_without_curl.patch b/net/git/patches/200-imapsend_without_curl.patch
index 75268a48f..c13336ef0 100644
--- a/net/git/patches/200-imapsend_without_curl.patch
+++ b/net/git/patches/200-imapsend_without_curl.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -1312,7 +1312,7 @@ else
+@@ -1365,7 +1365,7 @@ endif
endif
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
ifeq "$(curl_check)" "072200"
diff --git a/net/git/patches/300-openssl-deprecated.patch b/net/git/patches/300-openssl-deprecated.patch
index e3a9ad831..20a5a2a0b 100644
--- a/net/git/patches/300-openssl-deprecated.patch
+++ b/net/git/patches/300-openssl-deprecated.patch
@@ -12,11 +12,9 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
imap-send.c | 2 ++
1 file changed, 2 insertions(+)
-diff --git a/imap-send.c b/imap-send.c
-index b4eb886e2..877a4e368 100644
--- a/imap-send.c
+++ b/imap-send.c
-@@ -284,8 +284,10 @@ static int ssl_socket_connect(struct imap_socket *sock, int use_tls_only, int ve
+@@ -284,8 +284,10 @@ static int ssl_socket_connect(struct ima
int ret;
X509 *cert;
@@ -27,6 +25,3 @@ index b4eb886e2..877a4e368 100644
meth = SSLv23_method();
if (!meth) {
---
-2.20.1
-