aboutsummaryrefslogtreecommitdiff
path: root/net/git-lfs/Makefile
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2020-11-16 12:15:01 +0100
committerJan Pavlinec <jan.pavlinec@nic.cz>2021-02-11 14:46:35 +0100
commit0bc2f89ae1d77de2f5a5ebb54b8e56f6d7e22b23 (patch)
treeb284f49544b552fc8b86d6d38abbd2915817bacb /net/git-lfs/Makefile
parent274302a60f51fafb964f62dc4835afbf4cf09200 (diff)
git-lfs: add new package
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'net/git-lfs/Makefile')
-rw-r--r--net/git-lfs/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/net/git-lfs/Makefile b/net/git-lfs/Makefile
new file mode 100644
index 000000000..2c388bdd9
--- /dev/null
+++ b/net/git-lfs/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2020-2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=git-lfs
+PKG_VERSION:=2.13.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/git-lfs/git-lfs/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=782e6275df9ca370730945112e16a0b8c64b9819f0b61fae52ba1ebbc8dce2d5
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE.md
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
+
+GO_PKG:=github.com/git-lfs/git-lfs
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/golang/golang-package.mk
+
+define Package/git-lfs
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Git Large File Storage
+ URL:=https://git-lfs.github.com
+ DEPENDS:=$(GO_ARCH_DEPENDS) +git
+endef
+
+define Package/git-lfs/description
+ Git Large File Storage (LFS) replaces large files such as audio samples,
+ videos, datasets, and graphics with text pointers inside Git, while storing
+ the file contents on a remote server like GitHub.com or GitHub Enterprise.
+endef
+
+$(eval $(call GoBinPackage,git-lfs))
+$(eval $(call BuildPackage,git-lfs))