aboutsummaryrefslogtreecommitdiff
path: root/net/geoip-shell/Makefile
diff options
context:
space:
mode:
authorAnton Khazan <antonk.d3v@gmail.com>2024-04-23 09:19:24 +0300
committerAnton Khazan <antonk.d3v@gmail.com>2024-04-23 09:19:24 +0300
commit199bd03b332bfb47fd44fc1762d941875d99d4f2 (patch)
tree3ab7188b6ee1e83c42443d2e9872ee2fb8236877 /net/geoip-shell/Makefile
parent466ed55d599c47a4f72cf6f96907fdfa5e9dcc79 (diff)
geoip-shell: update to v0.5.2
Changes since v0.5: Bugfixes: - bugfix: 'geoip-shell on' command errors out on iptables-based systems - bugfix: when changing the update cron schedule, old cron job does not get removed - bugfix: in some edge cases, the update cron job may not be created - bugfix: incorrect mask bits used when creating a rule allowing ipv6 link-local connections (/8 instead of /10) - bugfix: geoip-shell-fetch.sh: fix running without root permissions Improvements: - nftables variant: attach the base chain to the prerouting netfilter hook with priority -141 (rather than -150) to make rules processing deterministic when other rules exist which have priority 'mangle' (-150), making it easier to create custom rules which will be processed before geoip-shell rules - include information on currently used firewall backend utility (nftables or iptables) in the status report - avoid unnecessary re-fetching of ip lists when running 'geoip-shell configure' - randomize the default update schedule's minute between 10 and 20 (previously was always 15) - randomize the automatic update second between 0 and 59 - improve console messages and the status report - update and improve the general documentation - improve OpenWrt-specific documentation Signed-off-by: Anton Khazan <antonk.d3v@gmail.com>
Diffstat (limited to 'net/geoip-shell/Makefile')
-rw-r--r--net/geoip-shell/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/geoip-shell/Makefile b/net/geoip-shell/Makefile
index 494ef9fdf..c4385da8d 100644
--- a/net/geoip-shell/Makefile
+++ b/net/geoip-shell/Makefile
@@ -4,14 +4,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=geoip-shell
-PKG_VERSION:=0.5
-PKG_RELEASE:=2
+PKG_VERSION:=0.5.2
+PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=antonk <antonk.d3v@gmail.com>
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=3b56796aea49d7ae1e5ce3de1f5ccfafd36c7f3f
+PKG_SOURCE_VERSION:=db8bbf4ce04094843beea1b1aa4fbceb0d35688d
PKG_SOURCE_URL:=https://github.com/friendly-bits/geoip-shell-openwrt.git
-PKG_MIRROR_HASH:=2a6cb1996fc7c48f146267e193fe1812addeb228adc5fe16a55341509d4a5353
+PKG_MIRROR_HASH:=4b0b90a936b8e9b476a0b85bd2100fcc4d1da25cd6929c0bcc282ae7ff137e9f
include $(INCLUDE_DIR)/package.mk