aboutsummaryrefslogtreecommitdiff
path: root/net/gensio/Makefile
diff options
context:
space:
mode:
authorNita Vesa <werecatf@outlook.com>2022-03-30 10:26:02 +0300
committerRosen Penev <rosenp@gmail.com>2022-03-30 19:44:57 -0700
commitea3ad6b0909b2f5d8a8dcbc4e866c9ed22f3fb10 (patch)
treee23b9066b21364155fa34914349153839d87d091 /net/gensio/Makefile
parentff5837ee8f483bb425d33b18c1185586507d495c (diff)
gensio: Fix circular dependency error
Adding libsctp adds IPV6 dependency to gensio, so this patch is an attempt at working around that with the goal of getting rid of the circular dependency error. Signed-off-by: Nita Vesa <werecatf@outlook.com>
Diffstat (limited to 'net/gensio/Makefile')
-rw-r--r--net/gensio/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/gensio/Makefile b/net/gensio/Makefile
index 1895d4e8a..dd80e4b81 100644
--- a/net/gensio/Makefile
+++ b/net/gensio/Makefile
@@ -93,7 +93,7 @@ $(call Package/gensio/Default)
CATEGORY:=Libraries
ABI_VERSION:=0
MENU:=1
- DEPENDS:=+GENSIO_SSL:libopenssl +GENSIO_WRAP:libwrap +GENSIO_SCTP:libsctp +GENSIO_PTHREADS:libpthread +GENSIO_AVAHI:libavahi-client +GENSIO_TCL:tcl +GENSIO_GLIB:glib2 +GENSIO_SSHD:libpam
+ DEPENDS:=+GENSIO_SSL:libopenssl +GENSIO_WRAP:libwrap +(IPV6&&GENSIO_SCTP):libsctp +GENSIO_PTHREADS:libpthread +GENSIO_AVAHI:libavahi-client +GENSIO_TCL:tcl +GENSIO_GLIB:glib2 +GENSIO_SSHD:libpam
endef
define Package/libgensio/description