aboutsummaryrefslogtreecommitdiff
path: root/net/frr
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2023-05-16 15:57:08 +0000
committerNick Hainke <vincent@systemli.org>2023-05-16 18:56:30 +0200
commit4c9ab981e2702db66f6c4e31d5b2684d1f7e1a20 (patch)
tree0771972bc2e0e12b8fe02d47470fc2837f6e8531 /net/frr
parent7a251bd3ff3d775d231bec390b8002f0c48096a6 (diff)
frr: update to 8.5.1 branch
also fixes gcc 13 compile Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'net/frr')
-rw-r--r--net/frr/Makefile8
-rw-r--r--net/frr/patches/997-reverse_python_test.patch2
-rw-r--r--net/frr/patches/999-thread_reverse.patch8
3 files changed, 9 insertions, 9 deletions
diff --git a/net/frr/Makefile b/net/frr/Makefile
index 0f9f7fba8..b985c1f40 100644
--- a/net/frr/Makefile
+++ b/net/frr/Makefile
@@ -7,15 +7,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=frr
-PKG_VERSION:=8.4.2
+PKG_VERSION:=8.5.1
PKG_RELEASE:=1
-PKG_SOURCE_DATE:=2023-02-17
+PKG_SOURCE_DATE:=2023-05-12
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
-PKG_SOURCE_VERSION:=410d78b7a4f2c8b4d4c3736c6d6cdb710287ca80
+PKG_SOURCE_VERSION:=05469ab2b553302c2a7032f4c89e4510dc3fa6d9
PKG_SOURCE_URL:=https://codeload.github.com/FRRouting/frr/tar.gz/$(PKG_SOURCE_VERSION)?
-PKG_HASH:=1334b050ea3d4144efeb7bdfe9c6976ebc91744810c5d8a7381a53fac2877ea9
+PKG_HASH:=caf3fcf1998ecd9a08e67373921a2d4bf49dbfc707008d20a1d38fd1606ef298
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_SOURCE_VERSION)
diff --git a/net/frr/patches/997-reverse_python_test.patch b/net/frr/patches/997-reverse_python_test.patch
index 04a2884c0..8e454a456 100644
--- a/net/frr/patches/997-reverse_python_test.patch
+++ b/net/frr/patches/997-reverse_python_test.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -835,7 +835,6 @@ fi
+@@ -839,7 +839,6 @@ fi
#
AS_IF([test "$host" = "$build"], [
diff --git a/net/frr/patches/999-thread_reverse.patch b/net/frr/patches/999-thread_reverse.patch
index e7bf99e38..0f5b24bf6 100644
--- a/net/frr/patches/999-thread_reverse.patch
+++ b/net/frr/patches/999-thread_reverse.patch
@@ -1,6 +1,6 @@
--- a/lib/thread.c
+++ b/lib/thread.c
-@@ -870,13 +870,9 @@ static void thread_free(struct thread_ma
+@@ -868,13 +868,9 @@ static void thread_free(struct thread_ma
XFREE(MTYPE_THREAD, thread);
}
@@ -16,7 +16,7 @@
/*
* If timer_wait is null here, that means poll() should block
* indefinitely, unless the thread_master has overridden it by setting
-@@ -907,58 +903,15 @@ static int fd_poll(struct thread_master
+@@ -905,58 +901,15 @@ static int fd_poll(struct thread_master
rcu_assert_read_unlocked();
/* add poll pipe poker */
@@ -82,7 +82,7 @@
while (read(m->io_pipe[0], &trash, sizeof(trash)) > 0)
;
-@@ -1768,7 +1721,7 @@ struct thread *thread_fetch(struct threa
+@@ -1766,7 +1719,7 @@ struct thread *thread_fetch(struct threa
struct timeval zerotime = {0, 0};
struct timeval tv;
struct timeval *tw = NULL;
@@ -91,7 +91,7 @@
int num = 0;
do {
-@@ -1844,14 +1797,14 @@ struct thread *thread_fetch(struct threa
+@@ -1842,14 +1795,14 @@ struct thread *thread_fetch(struct threa
pthread_mutex_unlock(&m->mtx);
{