aboutsummaryrefslogtreecommitdiff
path: root/net/frr/patches
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2022-03-07 19:26:52 +0200
committerRosen Penev <rosenp@gmail.com>2022-03-08 21:56:19 -0800
commit9ffd55a993d803cf5e834d9c2ed118fafb892e45 (patch)
treebae2201d3e9674efb08eca60321fec73b3bd3384 /net/frr/patches
parent4d0d6eedfadb758d99ee76b52245038a5a1e7e43 (diff)
frr: update to 8.2
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'net/frr/patches')
-rw-r--r--net/frr/patches/098-fix_mips_libyang.patch2
-rw-r--r--net/frr/patches/997-reverse_python_test.patch10
-rw-r--r--net/frr/patches/998-mips64_fix.patch2
-rw-r--r--net/frr/patches/999-thread_reverse.patch8
4 files changed, 16 insertions, 6 deletions
diff --git a/net/frr/patches/098-fix_mips_libyang.patch b/net/frr/patches/098-fix_mips_libyang.patch
index 76bc87401..3cf24c985 100644
--- a/net/frr/patches/098-fix_mips_libyang.patch
+++ b/net/frr/patches/098-fix_mips_libyang.patch
@@ -1,6 +1,6 @@
--- a/lib/northbound.h
+++ b/lib/northbound.h
-@@ -592,11 +592,7 @@ struct frr_yang_module_info {
+@@ -593,11 +593,7 @@ struct frr_yang_module_info {
/* Priority - lower priorities are processed first. */
uint32_t priority;
diff --git a/net/frr/patches/997-reverse_python_test.patch b/net/frr/patches/997-reverse_python_test.patch
new file mode 100644
index 000000000..9b38b238c
--- /dev/null
+++ b/net/frr/patches/997-reverse_python_test.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -816,7 +816,6 @@ fi
+ #
+
+ AS_IF([test "$host" = "$build"], [
+- AM_PATH_PYTHON([3])
+ AC_CHECK_HEADER([gelf.h], [], [
+ AC_MSG_ERROR([libelf headers are required for building clippy. (Host only when cross-compiling.)])
+ ])
diff --git a/net/frr/patches/998-mips64_fix.patch b/net/frr/patches/998-mips64_fix.patch
index d2ed0a2d8..797c3d004 100644
--- a/net/frr/patches/998-mips64_fix.patch
+++ b/net/frr/patches/998-mips64_fix.patch
@@ -1,6 +1,6 @@
--- a/lib/xref.h
+++ b/lib/xref.h
-@@ -122,7 +122,7 @@ extern struct xref_block *xref_blocks;
+@@ -135,7 +135,7 @@ extern struct xref_block *xref_blocks;
extern void xref_block_add(struct xref_block *block);
extern void xref_gcc_workaround(const struct xref *xref);
diff --git a/net/frr/patches/999-thread_reverse.patch b/net/frr/patches/999-thread_reverse.patch
index cd7c3a7be..f3007e91a 100644
--- a/net/frr/patches/999-thread_reverse.patch
+++ b/net/frr/patches/999-thread_reverse.patch
@@ -1,6 +1,6 @@
--- a/lib/thread.c
+++ b/lib/thread.c
-@@ -824,13 +824,9 @@ static void thread_free(struct thread_ma
+@@ -830,13 +830,9 @@ static void thread_free(struct thread_ma
XFREE(MTYPE_THREAD, thread);
}
@@ -16,7 +16,7 @@
/*
* If timer_wait is null here, that means poll() should block
* indefinitely, unless the thread_master has overridden it by setting
-@@ -861,58 +857,15 @@ static int fd_poll(struct thread_master
+@@ -867,58 +863,15 @@ static int fd_poll(struct thread_master
rcu_assert_read_unlocked();
/* add poll pipe poker */
@@ -82,7 +82,7 @@
while (read(m->io_pipe[0], &trash, sizeof(trash)) > 0)
;
-@@ -1700,7 +1653,7 @@ struct thread *thread_fetch(struct threa
+@@ -1718,7 +1671,7 @@ struct thread *thread_fetch(struct threa
struct timeval zerotime = {0, 0};
struct timeval tv;
struct timeval *tw = NULL;
@@ -91,7 +91,7 @@
int num = 0;
do {
-@@ -1776,14 +1729,14 @@ struct thread *thread_fetch(struct threa
+@@ -1794,14 +1747,14 @@ struct thread *thread_fetch(struct threa
pthread_mutex_unlock(&m->mtx);
{