aboutsummaryrefslogtreecommitdiff
path: root/net/frp/Makefile
diff options
context:
space:
mode:
authorHuangbin Zhan <zhanhb88@gmail.com>2020-05-09 05:43:57 +0800
committerzhanhb <6323014+zhanhb@users.noreply.github.com>2020-05-09 06:06:43 +0800
commit0ec746ccb6e87696a7a4986d87d55cda205031f0 (patch)
treebe37c6909d1e1bb8f2f948cce1b4092841d8fa03 /net/frp/Makefile
parent0206a87146fef2b20d18187832935f63641f5c9b (diff)
treewide: add conffiles
Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
Diffstat (limited to 'net/frp/Makefile')
-rw-r--r--net/frp/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net/frp/Makefile b/net/frp/Makefile
index 9315d7faa..5a26e80b5 100644
--- a/net/frp/Makefile
+++ b/net/frp/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=frp
PKG_VERSION:=0.32.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/fatedier/frp/tar.gz/v${PKG_VERSION}?
@@ -61,6 +61,14 @@ define Package/frp/install
$(INSTALL_BIN) ./files/$(2).init $(1)/etc/init.d/$(2)
endef
+define Package/frpc/conffiles
+/etc/config/frpc
+endef
+
+define Package/frps/conffiles
+/etc/config/frps
+endef
+
define Package/frpc/install
$(call Package/frp/install,$(1),frpc)
endef