aboutsummaryrefslogtreecommitdiff
path: root/net/freeradius3
diff options
context:
space:
mode:
authorRobby K <robbyke@gmail.com>2018-08-20 20:02:14 +0200
committerRobby K <robbyke@gmail.com>2018-08-20 20:02:14 +0200
commitbb7b3204e05fa1e3d0505ad039e53b2a385a11ad (patch)
tree17e98c33188f8360e7df908e6779b8f3f22f4e21 /net/freeradius3
parentd9749c257b733ed3f193d7c22512a89ebd32a29b (diff)
freeradius3: Enable the EAP-PWD module.
This enables the EAP-PWD module, which allows for logging in with only a username and password, while still being secure (see the links below for the details of this EAP method, if interested). https://en.wikipedia.org/wiki/Extensible_Authentication_Protocol#EAP_Password_(EAP-PWD) Also found this blog post which talks about EAP-PWD and its benefits: https://dustri.org/b/eap-pwd-wifi-security-done-right.html Signed-off-by: Robby K <robbyke@gmail.com>
Diffstat (limited to 'net/freeradius3')
-rw-r--r--net/freeradius3/Makefile21
1 files changed, 19 insertions, 2 deletions
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index 21c974966..35d472f73 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=freeradius3
PKG_VERSION:=release_3_0_17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/FreeRADIUS/freeradius-server/archive
@@ -74,6 +74,7 @@ define Package/freeradius3-default
+freeradius3-mod-eap-peap \
+freeradius3-mod-eap-tls \
+freeradius3-mod-eap-ttls \
++freeradius3-mod-eap-pwd \
+freeradius3-mod-exec \
+freeradius3-mod-expiration \
+freeradius3-mod-expr \
@@ -183,6 +184,12 @@ define Package/freeradius3-mod-eap-ttls
TITLE:=EAP/TTLS module
endef
+define Package/freeradius3-mod-eap-pwd
+ $(call Package/freeradius3/Default)
+ DEPENDS:=freeradius3-mod-eap @FREERADIUS3_OPENSSL
+ TITLE:=EAP/PWD module
+endef
+
define Package/freeradius3-mod-exec
$(call Package/freeradius3/Default)
DEPENDS:=freeradius3
@@ -397,7 +404,6 @@ CONFIGURE_ARGS+= \
--without-rlm_couchbase \
--without-rlm_counter \
--without-rlm_eap_ikev2 \
- --without-rlm_eap_pwd \
--without-rlm_eap_sim \
--without-rlm_eap_tnc \
--without-rlm_example \
@@ -468,6 +474,16 @@ else
CONFIGURE_ARGS+= --without-rlm_eap_ttls
endif
+ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius3-mod-eap-pwd),)
+ CONFIGURE_ARGS+= \
+ --with-rlm_eap_pwd \
+ --with-rlm_eap_pwd-include-dir="$(STAGING_DIR)/usr/include" \
+ --with-rlm_eap_pwd-lib-dir="$(STAGING_DIR)/usr/lib"
+ CONFIGURE_LIBS+= -lcrypto -lssl
+else
+ CONFIGURE_ARGS+= --without-rlm_eap_pwd
+endif
+
ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius3-mod-radutmp),)
CONFIGURE_ARGS+= --with-rlm_radutmp
else
@@ -605,6 +621,7 @@ $(eval $(call BuildPlugin,freeradius3-mod-eap-peap,rlm_eap_peap,))
$(eval $(call BuildPlugin,freeradius3-mod-eap,rlm_eap,))
$(eval $(call BuildPlugin,freeradius3-mod-eap-tls,rlm_eap_tls,))
$(eval $(call BuildPlugin,freeradius3-mod-eap-ttls,rlm_eap_ttls,))
+$(eval $(call BuildPlugin,freeradius3-mod-eap-pwd,rlm_eap_pwd,))
$(eval $(call BuildPlugin,freeradius3-mod-exec,rlm_exec,))
$(eval $(call BuildPlugin,freeradius3-mod-expiration,rlm_expiration,))
$(eval $(call BuildPlugin,freeradius3-mod-expr,rlm_expr,))