aboutsummaryrefslogtreecommitdiff
path: root/net/freeradius3
diff options
context:
space:
mode:
authorDaniel Golle <dangowrt@users.noreply.github.com>2017-06-05 16:51:38 +0200
committerGitHub <noreply@github.com>2017-06-05 16:51:38 +0200
commit92b2a187bb0b5e8966d423035f3baf654289fe42 (patch)
treec39bb2f39d3168baa883f55ac7c4de39bbc71d3e /net/freeradius3
parent3527f34b3e5dcac27518cc1f92f398d49dd69936 (diff)
parentc275909c38e86f0e84fde60256e425f073f1f3f6 (diff)
Merge pull request #4099 from dangowrt/freeradius3-ldap
freeradius3: build and package support for LDAP
Diffstat (limited to 'net/freeradius3')
-rw-r--r--net/freeradius3/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index a71c21486..cf55b2994 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -274,7 +274,15 @@ define Package/freeradius3-mod-passwd/conffiles
/etc/freeradius3/mods-enabled/passwd
endef
-# LDAP support has not been ported
+define Package/freeradius3-mod-ldap
+ $(call Package/freeradius3/Default)
+ DEPENDS:=freeradius3 +libopenldap @FREERADIUS3_OPENSSL
+ TITLE:=LDAP Authentication
+endef
+
+define Package/freeradius3-mod-ldap/conffiles
+/etc/freeradius3/mods-available/ldap
+endef
define Package/freeradius3-mod-logintime
$(call Package/freeradius3/Default)
@@ -396,7 +404,6 @@ CONFIGURE_ARGS+= \
--without-rlm_idn \
--without-rlm_ippool \
--without-rlm_krb5 \
- --without-rlm_ldap \
--without-rlm_opendirectory \
--without-rlm_pam \
--without-rlm_perl \
@@ -473,6 +480,14 @@ else
CONFIGURE_ARGS+= --without-rlm_unix
endif
+ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius3-mod-ldap),)
+ CONFIGURE_ARGS+= --with-rlm_ldap \
+ --with-rlm_ldap-include-dir="$(STAGING_DIR)/usr/include" \
+ --with-rlm_ldap-lib-dir="$(STAGING_DIR)/usr/lib"
+else
+ CONFIGURE_ARGS+= --without-rlm_ldap
+endif
+
CONFIGURE_VARS+= \
LDFLAGS="$$$$LDFLAGS" \
LIBS="$(CONFIGURE_LIBS)" \
@@ -587,6 +602,7 @@ $(eval $(call BuildPlugin,freeradius3-mod-exec,rlm_exec,))
$(eval $(call BuildPlugin,freeradius3-mod-expiration,rlm_expiration,))
$(eval $(call BuildPlugin,freeradius3-mod-expr,rlm_expr,))
$(eval $(call BuildPlugin,freeradius3-mod-files,rlm_files,))
+$(eval $(call BuildPlugin,freeradius3-mod-ldap,rlm_ldap,))
$(eval $(call BuildPlugin,freeradius3-mod-logintime,rlm_logintime,))
$(eval $(call BuildPlugin,freeradius3-mod-mschap,rlm_mschap,))
$(eval $(call BuildPlugin,freeradius3-mod-pap,rlm_pap,))