aboutsummaryrefslogtreecommitdiff
path: root/net/freeradius3
diff options
context:
space:
mode:
authorAlexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>2020-09-05 01:31:28 +0300
committerAlexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>2020-09-05 01:31:28 +0300
commit8b2792adc904045ca58ad077496f19ef634dc960 (patch)
treee2dd04c51fc7d96d9ea9745501dec69df16d6dd8 /net/freeradius3
parent6480acde4b08c46dd9d270a46005fe6f24e9a0b2 (diff)
freeradius3: fix hostname invocation in radtest
Canonical radtest start results in an error: $ radtest bob hello localhost 0 testing123 /usr/bin/radtest: line 1: hostname: not found (0) Error parsing "stdin": Failed to get value hostname command is not present in OpenWrt. Instead, hostname can be obtained from file /proc/sys/kernel/hostname. added: 004-get-hostname-from-proc-in-radtest.patch Signed-off-by: Alexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>
Diffstat (limited to 'net/freeradius3')
-rw-r--r--net/freeradius3/Makefile2
-rw-r--r--net/freeradius3/patches/004-get-hostname-from-proc-in-radtest.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index 992a7689f..1366e5c10 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=freeradius3
PKG_VERSION:=release_3_0_21
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/FreeRADIUS/freeradius-server/archive
diff --git a/net/freeradius3/patches/004-get-hostname-from-proc-in-radtest.patch b/net/freeradius3/patches/004-get-hostname-from-proc-in-radtest.patch
new file mode 100644
index 000000000..c3f368e24
--- /dev/null
+++ b/net/freeradius3/patches/004-get-hostname-from-proc-in-radtest.patch
@@ -0,0 +1,12 @@
+--- a/src/main/radtest.in
++++ b/src/main/radtest.in
+@@ -112,7 +112,7 @@ if [ "$7" ]
+ then
+ nas=$7
+ else
+- nas=`hostname`
++ nas=$(cat /proc/sys/kernel/hostname)
+ fi
+
+ (
+