aboutsummaryrefslogtreecommitdiff
path: root/net/flent
diff options
context:
space:
mode:
authorToke Høiland-Jørgensen <toke@toke.dk>2022-12-17 22:02:35 +0100
committerToke Høiland-Jørgensen <toke@toke.dk>2022-12-17 23:42:51 +0100
commit6818f1e521236f1d21478b1d693db785129bd7cf (patch)
treeb4d00f7506d4a0883b4418876e13d08f3af8aefb /net/flent
parent44e1c2115ea91b97e9454c19428a59f155e9f677 (diff)
flent: Rename and update package
Update the Flent package and move it to net/, renaming it to just 'flent' instead of python3-flent (it's not a library, having the python3- prefix makes no sense). Also add python3-defusedxml as a dependency to protect against XML bombs if using the one of the backends that use XML-RPC, and trim the dependencies to those used directly by Flent. Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
Diffstat (limited to 'net/flent')
-rw-r--r--net/flent/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/net/flent/Makefile b/net/flent/Makefile
new file mode 100644
index 000000000..15180f251
--- /dev/null
+++ b/net/flent/Makefile
@@ -0,0 +1,41 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=flent
+PKG_VERSION:=2.1.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=flent
+PKG_HASH:=db581deac3d8099965dd0d8eee4b9c4d1857bdce5bc97790af9d3ed5b6554f73
+
+PKG_MAINTAINER:=Nick Hainke <vincent@systemli.org>
+PKG_LICENSE:=GPL-3.0-only
+PKG_LICENSE_FILES:=LICENSE
+
+include ../../lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/python/python3-package.mk
+
+define Package/flent
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=The FLExible Network Tester
+ URL:=https://flent.org
+ CONFLICTS:=python3-flent
+ DEPENDS:= \
+ +python3-light \
+ +python3-uuid \
+ +python3-logging \
+ +python3-distutils \
+ +python3-defusedxml \
+ +netperf \
+ +fping
+endef
+
+define Package/flent/description
+ Flent is a Python wrapper to run multiple simultaneous
+ netperf/iperf/ping instances and aggregate the results.
+endef
+
+$(eval $(call Py3Package,flent))
+$(eval $(call BuildPackage,flent))
+$(eval $(call BuildPackage,flent-src))