aboutsummaryrefslogtreecommitdiff
path: root/net/fakepop
diff options
context:
space:
mode:
authorMarc Egerton <foxtrot@realloc.me>2020-08-22 16:09:30 +0100
committerMarc Egerton <foxtrot@realloc.me>2020-08-22 16:19:05 +0100
commitb5680054440c28ee69d8413f63308414978b889b (patch)
treea75fba757a59dae449177597acc75db66b3e0305 /net/fakepop
parentcb092479b5541497af8fa804ce867d458269ab9b (diff)
fakepop: new package
fakepop is a fake pop3 daemon. It returns always the same messages to all users, it does not care about usernames and passwords. All user/pass combinations are accepted. Signed-off-by: Marc Egerton <foxtrot@realloc.me>
Diffstat (limited to 'net/fakepop')
-rw-r--r--net/fakepop/Makefile42
-rw-r--r--net/fakepop/files/fakepop10
2 files changed, 52 insertions, 0 deletions
diff --git a/net/fakepop/Makefile b/net/fakepop/Makefile
new file mode 100644
index 000000000..03f22a4d2
--- /dev/null
+++ b/net/fakepop/Makefile
@@ -0,0 +1,42 @@
+#
+# This software is licensed under the Public Domain.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fakepop
+PKG_VERSION:=11
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Marc Egerton <foxtrot@realloc.me>
+PKG_LICENSE:=GPL-3.0
+
+PKG_SOURCE:=fakepop_11.tar.gz
+PKG_SOURCE_URL:=http://deb.debian.org/debian/pool/main/f/fakepop/
+PKG_HASH:=9756259ade152f8dac78174019b4145b4e07738631055c34bc04e64f865393e7
+# Downloaded .tar.gz contains "fakepop-10" instead of "fakepop-11"...
+PKG_BUILD_DIR:=$(BUILD_DIR)/fakepop-10
+
+include $(INCLUDE_DIR)/nls.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/fakepop
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=fakepop
+ DEPENDS:=+libc +glib2 +xinetd
+endef
+
+define Package/fakepop/description
+ fake pop3 server which returns the same messages to all users
+endef
+
+define Package/fakepop/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/fakepop $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/etc/xinetd.d
+ $(CP) ./files/fakepop $(1)/etc/xinetd.d/
+ mkdir $(1)/etc/fakepop
+endef
+
+$(eval $(call BuildPackage,fakepop))
diff --git a/net/fakepop/files/fakepop b/net/fakepop/files/fakepop
new file mode 100644
index 000000000..c1102936c
--- /dev/null
+++ b/net/fakepop/files/fakepop
@@ -0,0 +1,10 @@
+service pop3
+{
+ socket_type = stream
+ protocol = tcp
+ wait = no
+ user = nobody
+ server = /usr/bin/fakepop
+ port = 110
+ disable = no
+}