aboutsummaryrefslogtreecommitdiff
path: root/net/dnstop/Makefile
diff options
context:
space:
mode:
authorKen Xu <windedge99@gmail.com>2019-07-27 17:22:24 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2019-07-27 21:23:37 +0800
commit2e3a8c10abc1457fea3b3e4eea6bfac607bf64ac (patch)
treef5bc96d17018354b0c7df591551d631f0900201b /net/dnstop/Makefile
parent035dfd530c5237d5a9e28c6a04dde45c11033c01 (diff)
dnstop: add new package
Signed-off-by: Ken Xu <windedge99@gmail.com>
Diffstat (limited to 'net/dnstop/Makefile')
-rw-r--r--net/dnstop/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/dnstop/Makefile b/net/dnstop/Makefile
new file mode 100644
index 000000000..6681552db
--- /dev/null
+++ b/net/dnstop/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dnstop
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/measurement-factory/dnstop.git
+PKG_SOURCE_DATE:=2018-05-22
+PKG_SOURCE_VERSION:=a5a5d2e2ca9a433bb8f017682ac6f2085741bdf8
+PKG_MIRROR_HASH:=1fe443c6faf1726aeb86a53a3a44efce23cad604304036371e76ff020eb0dac2
+
+PKG_MAINTAINER:=Ken Xu <windedge99@gmail.com>
+PKG_LICENSE:=NLPL
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dnstop
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libpcap +libncurses
+ TITLE:=stay on top of your dns traffic
+ URL:=http://dns.measurement-factory.com/tools/dnstop/
+endef
+
+define Package/dnstop/description
+ dnstop is a libpcap application (like tcpdump) that displays various tables of DNS traffic on your network
+endef
+
+define Package/dnstop/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/dnstop $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,dnstop))