aboutsummaryrefslogtreecommitdiff
path: root/net/dnsproxy
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2021-09-02 05:31:15 +0800
committerJeffery To <jeffery.to@gmail.com>2021-09-02 05:31:15 +0800
commit8a6def501a90cbe4af9ecda867c4872b02470515 (patch)
tree95529bb4d8ac802ad9257e6a6d1d0bbffff2bdff /net/dnsproxy
parent1f132a184b60b3fc5e263a88d4b6559cd3adf819 (diff)
treewide: Remove GO_PKG_LDFLAGS for stripping binaries
The "-s -w" flags in GO_PKG_LDFLAGS tells the Go compiler to strip the binaries it produces. Since the default Go package build process will strip binaries when CONFIG_USE_STRIP or CONFIG_USE_SSTRIP are selected, these flags are unnecessary. When CONFIG_NO_STRIP is selected, these flags override the user's intention of building unstripped packages. This removes these flags for all relevant packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'net/dnsproxy')
-rw-r--r--net/dnsproxy/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/net/dnsproxy/Makefile b/net/dnsproxy/Makefile
index 74abf5ad0..d61a0818e 100644
--- a/net/dnsproxy/Makefile
+++ b/net/dnsproxy/Makefile
@@ -21,7 +21,6 @@ PKG_BUILD_PARALLEL:=1
PKG_USE_MIPS16:=0
GO_PKG:=github.com/AdguardTeam/dnsproxy
-GO_PKG_LDFLAGS:=-s -w
GO_PKG_LDFLAGS_X:=main.VersionString=v$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk