aboutsummaryrefslogtreecommitdiff
path: root/net/dnscrypt-proxy2
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2021-09-02 05:31:15 +0800
committerJeffery To <jeffery.to@gmail.com>2021-09-02 05:31:15 +0800
commit8a6def501a90cbe4af9ecda867c4872b02470515 (patch)
tree95529bb4d8ac802ad9257e6a6d1d0bbffff2bdff /net/dnscrypt-proxy2
parent1f132a184b60b3fc5e263a88d4b6559cd3adf819 (diff)
treewide: Remove GO_PKG_LDFLAGS for stripping binaries
The "-s -w" flags in GO_PKG_LDFLAGS tells the Go compiler to strip the binaries it produces. Since the default Go package build process will strip binaries when CONFIG_USE_STRIP or CONFIG_USE_SSTRIP are selected, these flags are unnecessary. When CONFIG_NO_STRIP is selected, these flags override the user's intention of building unstripped packages. This removes these flags for all relevant packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'net/dnscrypt-proxy2')
-rw-r--r--net/dnscrypt-proxy2/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/net/dnscrypt-proxy2/Makefile b/net/dnscrypt-proxy2/Makefile
index 53744c384..2b2366b71 100644
--- a/net/dnscrypt-proxy2/Makefile
+++ b/net/dnscrypt-proxy2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnscrypt-proxy2
PKG_VERSION:=2.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=dnscrypt-proxy-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/DNSCrypt/dnscrypt-proxy/tar.gz/$(PKG_VERSION)?
@@ -25,7 +25,6 @@ PKG_BUILD_PARALLEL:=1
PKG_USE_MIPS16:=0
GO_PKG:=github.com/DNSCrypt/dnscrypt-proxy
-GO_PKG_LDFLAGS:=-s -w
include $(INCLUDE_DIR)/package.mk
include ../../lang/golang/golang-package.mk