aboutsummaryrefslogtreecommitdiff
path: root/net/ddns-scripts
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2020-09-09 17:27:12 +0200
committerFlorian Eckert <fe@dev.tdt.de>2020-09-21 10:17:01 +0200
commite051d3772012e97cbaec219ba5fefa453f1907c0 (patch)
tree77573c3771fc35520a6fdd03e00f3bee15b1690f /net/ddns-scripts
parentcabdcdf795de70735a93912d3a3d9ca032100c27 (diff)
ddns-scripts: update bind-nsupdate to json
Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'net/ddns-scripts')
-rwxr-xr-xnet/ddns-scripts/Makefile17
-rw-r--r--[-rwxr-xr-x]net/ddns-scripts/files/usr/lib/ddns/update_nsupdate.sh (renamed from net/ddns-scripts/files/update_nsupdate.sh)0
-rw-r--r--net/ddns-scripts/files/usr/share/ddns/services/bind-nsupdate.json9
3 files changed, 16 insertions, 10 deletions
diff --git a/net/ddns-scripts/Makefile b/net/ddns-scripts/Makefile
index fe9497787..1a82b298c 100755
--- a/net/ddns-scripts/Makefile
+++ b/net/ddns-scripts/Makefile
@@ -432,17 +432,17 @@ endef
define Package/ddns-scripts_nsupdate/install
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/ddns.defaults $(1)/etc/uci-defaults/ddns_nsupdate
+
$(INSTALL_DIR) $(1)/usr/lib/ddns
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/files/update_nsupdate.sh $(1)/usr/lib/ddns
+ $(INSTALL_BIN) ./files/usr/lib/ddns/update_nsupdate.sh \
+ $(1)/usr/lib/ddns
+
+ $(INSTALL_DIR) $(1)/usr/share/ddns/services
+ $(INSTALL_DATA) ./files/usr/share/ddns/services/bind-nsupdate.json \
+ $(1)/usr/share/ddns/services
endef
define Package/ddns-scripts_nsupdate/postinst
#!/bin/sh
- # remove old services file entries
- /bin/sed -i '/bind-nsupdate/d' $${IPKG_INSTROOT}/etc/ddns/services >/dev/null 2>&1
- /bin/sed -i '/bind-nsupdate/d' $${IPKG_INSTROOT}/etc/ddns/services_ipv6 >/dev/null 2>&1
- # and create new
- printf "%s\\t%s\\n" '"bind-nsupdate"' '"update_nsupdate.sh"' >> $${IPKG_INSTROOT}/etc/ddns/services
- printf "%s\\t%s\\n" '"bind-nsupdate"' '"update_nsupdate.sh"' >> $${IPKG_INSTROOT}/etc/ddns/services_ipv6
# on real system restart service if enabled
[ -z "$${IPKG_INSTROOT}" ] && {
[ -x /etc/uci-defaults/ddns_nsupdate ] && \
@@ -457,9 +457,6 @@ define Package/ddns-scripts_nsupdate/prerm
#!/bin/sh
# if NOT run buildroot then stop service
[ -z "$${IPKG_INSTROOT}" ] && /etc/init.d/ddns stop >/dev/null 2>&1
- # remove services file entries
- /bin/sed -i '/bind-nsupdate/d' $${IPKG_INSTROOT}/etc/ddns/services >/dev/null 2>&1
- /bin/sed -i '/bind-nsupdate/d' $${IPKG_INSTROOT}/etc/ddns/services_ipv6 >/dev/null 2>&1
exit 0 # suppress errors
endef
diff --git a/net/ddns-scripts/files/update_nsupdate.sh b/net/ddns-scripts/files/usr/lib/ddns/update_nsupdate.sh
index 039196ff8..039196ff8 100755..100644
--- a/net/ddns-scripts/files/update_nsupdate.sh
+++ b/net/ddns-scripts/files/usr/lib/ddns/update_nsupdate.sh
diff --git a/net/ddns-scripts/files/usr/share/ddns/services/bind-nsupdate.json b/net/ddns-scripts/files/usr/share/ddns/services/bind-nsupdate.json
new file mode 100644
index 000000000..f91806a15
--- /dev/null
+++ b/net/ddns-scripts/files/usr/share/ddns/services/bind-nsupdate.json
@@ -0,0 +1,9 @@
+{
+ "name": "bind-nsupdate",
+ "ipv4": {
+ "url": "update_nsupdate.sh"
+ },
+ "ipv6": {
+ "url": "update_nsupdate.sh"
+ }
+}