aboutsummaryrefslogtreecommitdiff
path: root/net/ddns-scripts
diff options
context:
space:
mode:
authorJoel Johnson <mrjoel@lixil.net>2020-08-21 13:51:18 -0600
committerJoel Johnson <mrjoel@lixil.net>2020-10-21 08:43:18 -0600
commit5b362932a7df5ce44ca3a8f4cf1d2b225ca8d5ae (patch)
tree8e2ffe5ec85c8bc5d20d13523f08f808549ea2f0 /net/ddns-scripts
parent4315b0e4f2d46ed45a6808847e8a579b7dbb0b47 (diff)
ddns-scripts: use ip_source as bind_network default
Fixes: #13182 on https://github.com/openwrt/packages Signed-off-by: Joel Johnson <mrjoel@lixil.net>
Diffstat (limited to 'net/ddns-scripts')
-rw-r--r--net/ddns-scripts/Makefile2
-rw-r--r--net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh3
2 files changed, 4 insertions, 1 deletions
diff --git a/net/ddns-scripts/Makefile b/net/ddns-scripts/Makefile
index 912e6d860..e8a5c9eee 100644
--- a/net/ddns-scripts/Makefile
+++ b/net/ddns-scripts/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ddns-scripts
PKG_VERSION:=2.8.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
diff --git a/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh b/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
index a5698d7f2..eeb212ec1 100644
--- a/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
+++ b/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
@@ -707,6 +707,9 @@ do_transfer() {
[ $# -ne 1 ] && write_log 12 "Error in 'do_transfer()' - wrong number of parameters"
+ # Use ip_network as default for bind_network if not separately specified
+ [ -z "$bind_network" ] && [ "$ip_source" = "network" ] && [ "$ip_network" ] && bind_network="$ip_network"
+
# lets prefer GNU Wget because it does all for us - IPv4/IPv6/HTTPS/PROXY/force IP version
if [ -n "$WGET_SSL" -a $USE_CURL -eq 0 ]; then # except global option use_curl is set to "1"
__PROG="$WGET_SSL --hsts-file=/tmp/.wget-hsts -nv -t 1 -O $DATFILE -o $ERRFILE" # non_verbose no_retry outfile errfile