aboutsummaryrefslogtreecommitdiff
path: root/net/ddns-scripts/Makefile
diff options
context:
space:
mode:
authorLuca Conte <main@lugico.de>2022-01-19 15:56:47 +0100
committerLuca Conte <main@lugico.de>2022-01-27 13:59:42 +0100
commit60047cdce1ec57546316c6ea89cf51a1c858d40c (patch)
tree330cc507b744521a6e2bbd684c6076f1e3c1ec0c /net/ddns-scripts/Makefile
parenta1cdf51ba89dced60d81c9adcbade5cb2d29a6a0 (diff)
ddns-scripts: add one.com provider
Signed-off-by: Luca Conte <main@lugico.de>
Diffstat (limited to 'net/ddns-scripts/Makefile')
-rw-r--r--net/ddns-scripts/Makefile37
1 files changed, 36 insertions, 1 deletions
diff --git a/net/ddns-scripts/Makefile b/net/ddns-scripts/Makefile
index 34a366a56..873a33b1f 100644
--- a/net/ddns-scripts/Makefile
+++ b/net/ddns-scripts/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ddns-scripts
PKG_VERSION:=2.8.2
-PKG_RELEASE:=21
+PKG_RELEASE:=22
PKG_LICENSE:=GPL-2.0
@@ -237,6 +237,20 @@ define Package/ddns-scripts-transip/description
"option param_opt" to contain the TTL of the DNS record to update
endef
+define Package/ddns-scripts-one
+ $(call Package/ddns-scripts/Default)
+ TITLE:=Extension for one.com Control Panel
+ DEPENDS:=ddns-scripts +curl
+endef
+
+define Package/ddns-scrtips-one/description
+ Dynamic DNS Client scripts extension for "one.com".
+ It requires:
+ "option username" to be a valid Email for one.com Control Panel
+ "option password" to be the matching one.com Control Panel password
+ "option domain" to contain the domain / subdomain
+endef
+
define Build/Configure
endef
@@ -312,6 +326,7 @@ define Package/ddns-scripts-services/install
rm $(1)/usr/share/ddns/default/pdns.json
rm $(1)/usr/share/ddns/default/transip.nl.json
rm $(1)/usr/share/ddns/default/ns1.com.json
+ rm $(1)/usr/share/ddns/default/one.com.json
endef
@@ -562,6 +577,25 @@ exit 0
endef
+define Package/ddns-scripts-one/install
+ $(INSTALL_DIR) $(1)/usr/lib/ddns
+ $(INSTALL_BIN) ./files/usr/lib/ddns/update_one_com.sh \
+ $(1)/usr/lib/ddns
+
+ $(INSTALL_DIR) $(1)/usr/share/ddns/default
+ $(INSTALL_DATA) ./files/usr/share/ddns/default/one.com.json \
+ $(1)/usr/share/ddns/default
+endef
+
+define Package/ddns-scripts-one/prerm
+#!/bin/sh
+if [-z "${IPKG_INSTROOT}" ]; then
+ /etc/init.d/ddns stop
+fi
+exit 0
+endef
+
+
$(eval $(call BuildPackage,ddns-scripts))
$(eval $(call BuildPackage,ddns-scripts-services))
$(eval $(call BuildPackage,ddns-scripts-cloudflare))
@@ -577,3 +611,4 @@ $(eval $(call BuildPackage,ddns-scripts-gandi))
$(eval $(call BuildPackage,ddns-scripts-pdns))
$(eval $(call BuildPackage,ddns-scripts-transip))
$(eval $(call BuildPackage,ddns-scripts-ns1))
+$(eval $(call BuildPackage,ddns-scripts-one))