aboutsummaryrefslogtreecommitdiff
path: root/net/dcwapd/Makefile
diff options
context:
space:
mode:
authorCarey Sonsino <csonsino@gmail.com>2019-11-13 13:05:47 -0500
committerCarey Sonsino <csonsino@gmail.com>2019-11-15 18:06:05 -0500
commit0d5b50c4bf16cbb6acbb680b8a72a2b0ae2b917d (patch)
tree5723a544f51647ab7fda237c1d3ff86d7c05e56e /net/dcwapd/Makefile
parent526b384503e217d428ca4bbe9b546e1653b7b117 (diff)
dcwapd: Update init script to use procd
consolidate shell scripts into init script remove "litter" from uci file update default UCI values Signed-off-by: Carey Sonsino <careys@edgewaterwireless.com> Signed-off-by: Carey Sonsino <csonsino@gmail.com>
Diffstat (limited to 'net/dcwapd/Makefile')
-rw-r--r--net/dcwapd/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/net/dcwapd/Makefile b/net/dcwapd/Makefile
index 0fe336298..3566f50fe 100644
--- a/net/dcwapd/Makefile
+++ b/net/dcwapd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dcwapd
PKG_VERSION:=1.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/ewsi/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
@@ -58,19 +58,12 @@ define Package/dcwapd/install
# Note: $(INSTALL_BIN) does not keep symlinks, so use $(CP)
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
-# Utility files
- $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
- $(INSTALL_DATA) ./files/*.inc $(1)/etc/$(PKG_NAME)/
- $(INSTALL_BIN) ./files/*.sh $(1)/etc/$(PKG_NAME)/
-# UCI config file copy - this is here for convenience and reference only
- $(INSTALL_DATA) ./files/dcwapd.uci $(1)/etc/$(PKG_NAME)/
-
# UCI config file
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/dcwapd.uci $(1)/etc/config/dcwapd
# Init script
$(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/dcwapd.init.d $(1)/etc/init.d/dcwapd
+ $(INSTALL_BIN) ./files/dcwapd.init $(1)/etc/init.d/dcwapd
endef
$(eval $(call BuildPackage,dcwapd))