aboutsummaryrefslogtreecommitdiff
path: root/net/davfs2/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-11 21:24:43 -0700
committerRosen Penev <rosenp@gmail.com>2020-08-19 14:35:40 -0700
commitc03f25a00a36861a23ea500c0fcb2d6bd3f827b9 (patch)
treefbf95139b39d013a716b918ddfdcb726574663a6 /net/davfs2/patches
parentf7041ed34ac82a26736f9046999b832e6ad672f5 (diff)
davfs2: update to 1.6.0
Removed now unnecessary gcc10 patch. Removed neon patch. It's now upstream. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/davfs2/patches')
-rw-r--r--net/davfs2/patches/020-neon.patch11
-rw-r--r--net/davfs2/patches/050-sys-types.patch (renamed from net/davfs2/patches/050-sys-types.h)0
-rw-r--r--net/davfs2/patches/070-no-error.patch3
-rw-r--r--net/davfs2/patches/400-gcc10.patch11
4 files changed, 2 insertions, 23 deletions
diff --git a/net/davfs2/patches/020-neon.patch b/net/davfs2/patches/020-neon.patch
deleted file mode 100644
index e46be6a95..000000000
--- a/net/davfs2/patches/020-neon.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -36,7 +36,7 @@ AC_PROG_LN_S
- # Checks for libraries.
- AM_GNU_GETTEXT_VERSION(0.18.1)
- AM_GNU_GETTEXT([external])
--NE_REQUIRE_VERSIONS([0], [27 28 29 30])
-+NE_REQUIRE_VERSIONS([0], [27 28 29 30 31])
- DAV_CHECK_NEON
-
- # Checks for header files.
diff --git a/net/davfs2/patches/050-sys-types.h b/net/davfs2/patches/050-sys-types.patch
index 9478b8b78..9478b8b78 100644
--- a/net/davfs2/patches/050-sys-types.h
+++ b/net/davfs2/patches/050-sys-types.patch
diff --git a/net/davfs2/patches/070-no-error.patch b/net/davfs2/patches/070-no-error.patch
index fb3966b1f..a6140d5dd 100644
--- a/net/davfs2/patches/070-no-error.patch
+++ b/net/davfs2/patches/070-no-error.patch
@@ -69,12 +69,13 @@
+#endif /* _COMPAT_H */
--- a/src/kernel_interface.c
+++ b/src/kernel_interface.c
-@@ -19,8 +19,8 @@
+@@ -19,9 +19,9 @@
#include "config.h"
+#include "compat.h"
+ #include <errno.h>
-#include <error.h>
#ifdef HAVE_FCNTL_H
#include <fcntl.h>
diff --git a/net/davfs2/patches/400-gcc10.patch b/net/davfs2/patches/400-gcc10.patch
deleted file mode 100644
index 046c67e58..000000000
--- a/net/davfs2/patches/400-gcc10.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/dav_coda.c
-+++ b/src/dav_coda.c
-@@ -97,7 +97,7 @@ static unsigned int blocksize;
- static size_t alignment;
-
- /* Send debug messages to syslog if != 0. */
--int debug;
-+extern int debug;
-
-
- /* Private function prototypes */