aboutsummaryrefslogtreecommitdiff
path: root/net/darkstat
diff options
context:
space:
mode:
authorJean-Michel Lacroix <lacroix@lepine-lacroix.info>2020-07-01 18:40:42 -0400
committerJean-Michel Lacroix <lacroix@lepine-lacroix.info>2020-07-01 18:40:42 -0400
commitcd13e7ec7e8e00f66b4c48b1560dc73cd4620365 (patch)
tree1d1579b288fd84b9060fb7bb768ed26dc82926a0 /net/darkstat
parent961016a84f027534a350e6d6b773c7c934d8d129 (diff)
darkstat: correct incompatbility with sshd
The init file of darkstat is creating the pid in /var/empty and setting the owner of the directory to darkstat which is incompatible with sshd as sshd requires /var/empty to be owned by root and not group or world-writable. See issue #12420. This corrects the problem by creating another directory: /var/darkstat instead without setting the owner, which is not actually required. Compile tested: not applicable as the changes do not involve compilation. Tested on my home router running darkstat. Signed-off-by: Jean-Michel Lacroix <lacroix@lepine-lacroix.info>
Diffstat (limited to 'net/darkstat')
-rw-r--r--net/darkstat/Makefile2
-rwxr-xr-xnet/darkstat/files/darkstat.init3
2 files changed, 2 insertions, 3 deletions
diff --git a/net/darkstat/Makefile b/net/darkstat/Makefile
index f7c8508f7..c57005127 100644
--- a/net/darkstat/Makefile
+++ b/net/darkstat/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=darkstat
PKG_VERSION:=3.0.719
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_MAINTAINER:=Jean-Michel Lacroix <lacroix@lepine-lacroix.info>
diff --git a/net/darkstat/files/darkstat.init b/net/darkstat/files/darkstat.init
index 4cd8b3ef3..523322012 100755
--- a/net/darkstat/files/darkstat.init
+++ b/net/darkstat/files/darkstat.init
@@ -6,7 +6,7 @@ USE_PROCD=1
START=60
APP=darkstat
-RUN_D=/var/empty
+RUN_D=/var/darkstat
PID_F=$RUN_D/$APP.pid
CONFIGNAME=darkstat
USER=nobody
@@ -30,7 +30,6 @@ export_bool () {
set_config_string(){
mkdir -p $RUN_D
- chown $USER:$GROUP $RUN_D
. /lib/functions/network.sh
config_load $CONFIGNAME
config_foreach build_config_string darkstat